
RPA Tutorial: Parse Excel Files

Create a robotic task that retrieves Excel file data
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Welcome to the RPA Tutorial: Parse Excel Files

This tutorial looks at a fictional company, Acme Office Supplies, and how they handle
extracting data from an Excel file and using it in an Appian application.

Before you start this tutorial, you will need the following:

● Completion of the online course: Create Robotic Tasks with Appian.
● A computer to use as a resource – either your own computer or a remote

desktop. The resource should meet or exceed the following requirements:
○ Java 8
○ 4GB of RAM
○ 64-bit Windows OS

● Access to your Appian Community Edition or System Administrator access to
Appian RPA in a different development environment. You can request an Appian
Community Edition with the following steps:

1. Navigate to the Appian Community website, and log into your Appian
Community Edition account.

2. Click the Learn tab.
3. Click the My Learning Journey icon.
4. Click Get my site in the My Community Edition Site card.
5. Choose your region, and generate your site.

● A download of the Excel file used in this tutorial

There are some steps in the tutorial that require a system administrator. If you are
using your Appian Community Edition, you can perform these steps. If you are using a
different environment, you must have a system administrator perform these steps for
you. The system administrator steps are flagged in blue. Let’s get started!
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Use Case

Every week, the Acme Sales team puts business opportunities into a file sharing system.
For this tutorial, that system will be a folder on the desktop. They are transitioning
some of their business processes to use Appian applications, and they want to get the
business opportunity Excel data into Appian. In this tutorial, you will create an
application and a robotic task to meet the requirements for this use case.

You will use the Excel (License Not Required) Actions available in the RPA Actions
Palette to automate the process of reading and saving data from an Excel file. Although
you are using RPA for this tutorial, there are other ways to automate Excel using
Appian. For more guidance on these options, visit Appian Documentation.

After completing this tutorial, you will be able to:
● Add a robot
● Create a robotic task that uses low-code actions to open an Excel workbook from

a desktop folder and retrieve the workbook data
● Add the robotic task to a process model
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Robot Setup

Add a Robot

These steps require you to be a system administrator in your environment.

If you have previously added a robot, you can skip steps 1 - 7. If you have also
downloaded the RPA agent to your host machine, you can skip this section and move
on to adding the Excel file to your host machine.

1. Log into your environment and select Operations Console from the navigation
menu, the same way you access Appian Designer.

2. Click CREATE.
3. Enter the name of your robot and permission tags. Remember, permission tags

are used to set security between your user account and robots. The permission
here should match permission tags for your user.

4. Click CONTINUE.
5. Select Windows for your operating system and the JRE Path if it is different from

the listed default.
6. If you want to use the automatic sign in feature, select the checkbox.
7. Click CREATE.
8. Download the installer.

a. If you’re using your computer as the host machine, you can download the
installer now.

b. If you are using a remote desktop as the host machine, make sure to
download the installer on the remote desktop. To access and download
the installer, navigate to your Appian Environment > Operations Console >
Your Robot > Manage Connection and download the installer. You may
have to select More Info to run the installer.

9. Create a new folder, Appian, on your host machine (your computer or remote
desktop).

10.Add the rpa-installer.exe file to the Appian folder.
11.Run the rpa-installer.exe file.

a. You may have to click More Info to run the file.

Add the Excel File to the Host Machine

Next, you need to set up the “file sharing system” for Acme Sales. For this exercise, the
“file sharing system” will be a folder on your desktop.
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1. Create a new folder, Business Opportunities, on the desktop of your host
machine.

2. In the folder, add the Excel file you downloaded earlier.
3. Close the folder.

You have your host machine and your “file sharing system” set up. Let’s continue with
the tutorial.
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Create an Appian Application

If you’re not a system administrator in your development environment, you must be
added to the Process Model Creators and Designers system groups. If you are
using your Appian Community Edition, you are automatically added to these groups.

In this part of the exercise, you will create an application, a robot pool, connected
system, CDT, and data store. If you created an application and robot pool in a different
tutorial, you can skip this section and move on to getting your API key.

1. Log into your environment, and select Appian Designer from the navigation
menu.

2. Click New Application.
3. Complete the following details for your application:

● Name: RPA Tutorials.
● Description: Container for design objects used to execute the RPA

tutorial robotic tasks.
● Keep the checkbox selected to generate groups and folders.

4. Click CREATE.
5. Review the application security, and click SAVE.
6. Close the pop-up.
7. Navigate to the Build view.

8. Click New > Robot Pool.
9. Complete the following details:

● Name: RT_TrainingPool
● Description: Robot pool for training

10.Click CREATE.
11.Review the object security and click SAVE.
12.Click ADD MEMBERS.
13.In the Robots to Add field, search and select the robot you created in the

previous section.
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14.Click ADD.
15.Close this design object, and return to Appian Designer.

You created your application and a robot pool. You also added your previously created
robot to a pool. Let’s keep going!

Get Your API Key

Next, you will need an API key for the RPA connected system. If you are using your
Appian Community Edition, you can follow the steps below to generate the API key. If
you are on a different site, you will need access to the Admin Console before
completing the steps.

1. Use the navigation menu in the header to access Admin Console.
2. In the left pane, select Web API Authentication.
3. Click CREATE.
4. Complete the following details for the new API key.

● Description: Used for RPA in the Parse Excel Files Tutorial
application.

● Service Account:
i. If you are using your Appian Community Edition, you can use the

service account: AppianRPA.sa Service Account.
ii. If you are using a different site, you may need to create a new

service account.
● Click CREATE.

5. Copy the API key and paste it somewhere safe. You will need to access it later.
Click OK.

6. Navigate back to your application to create a connected system. Click NEW >
Connected System.

7. Select Appian RPA.
8. Complete the following details for the connected system:

● Name: RT Appian RPA CS
● Description: The connected system used with Appian RPA in the

Parse Excel Files tutorial.
● API Key: Paste the API key you saved from a previous step.
● Click TEST CONNECTION.
● If the connection is successful, click CREATE.
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9. Review security, and click SAVE.

Next, let’s create a CDT for the business opportunity data.

1. Click NEW > Data Type.
2. Complete the following details for the CDT:

● Namespace: Leave the default value.
● Name: RT_BusinessOpportunities
● Description: Structure of data for business opportunities.
● Click CREATE.

In Excel, the business opportunity data looks like this:

companyname companycontact emailaddress phonenumber

Mike’s Bike Shop Mike Smith Mike@Bikes.com 202-491-9999

Let’s add fields to the CDT to align with the business opportunity data.

3. Click New Field five times to add five fields.
4. Complete the following details for the first field:

● Name: businessOpportunityID
● Type: Number (Integer)
● Key: Selected

i. Key Constraint: Primary Key
ii. Auto-generate: Selected

● Click OK.
5. Use the following table to configure the remaining fields:

Name Type Length

companyName Text 255

companyContact Text 255

emailAddress Text 255

phoneNumber Text 255

6. Your CDT should look like this:
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7. Click SAVE CHANGES.

Navigate back to your application to create a data store.

1. Click NEW > Data Store.
2. Complete the following details for the data store:

● Name: RT Excel Data Tutorial DS
● Description: The data store used to communicate with the

database in the Parse Excel Files Tutorial.
● Data Source: Leave the default value.
● Click CREATE.

3. Review security, and click SAVE.
4. In the Data Entities section, click Add Entity.
5. For Name, type businessOpportunities.
6. Click in the Type field, and select the RT_BusinessOpportunities data type.
7. Click OK, then SAVE.
8. Scroll down to the Schema Management section, and click VERIFY. No

matching tables should be found. You want to create tables automatically, so
leave the default selection.

9. Click SAVE & PUBLISH.

You are now ready to set up a host machine to create and test your robotic task. Later,
you will finish configuring your application by adding your robotic task to a process
workflow.
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Create a Robotic Task

Next, create a robotic task.
1. Click NEW > Robotic Task.
2. Complete the following details:

a. Name: RT_ParseExcelFile
b. Description: Robotic task for the Parse Excel File tutorial
c. Robot Pools to Add: RT_TrainingPool

3. Click CREATE.
4. Review the security, and click SAVE.

Add Robotic Task Variables

For this tutorial, you need two robotic task variables: endingCell and dataValues.
1. In the right pane, click New Variable.

2. The first variable is for storing the ending cell. You will use this variable when
you add an Excel action to find the last cell in the spreadsheet. Complete the
following details for the first variable:

● Name: endingCell
● Type: Text
● Leave the rest of the fields blank.
● Click CREATE.

3. Click the Create Variable icon to create the second variable. This variable is for
storing all of the values in the spreadsheet up until the ending cell.

4. Complete the following details for the second variable:
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● Name: dataValues
● Type: RT_BusinessOpportunities
● Array: Selected
● Parameter: Selected
● Leave the remaining fields at their default value.
● Click OK.

5. Click SAVE CHANGES.

Now, let’s use these robotic task variables in the actions!
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Add Actions to Get Excel Data

Now, let’s build out our robotic task using low-code actions. You will add and configure
three actions: Open or Create Workbook, Find Range End, and Get Value. All of these
actions can be found in the palette under Excel: License Not Required.

1. Drag and drop the Open or Create Workbook (License Not Required) action
into the Main section.

2. This action will open the Excel file using a designated file path. Complete the
following details for the action:

● Display Name: Open Workbook
● Workbook Action: Open existing workbook
● File Path: Click the Expression Editor icon, and enter the file path for

your saved Excel file. For example:
"C:\Users\Administrator\Desktop\Business
Opportunities\BusinessOpportunitiesData_ExcelTutorial.
xlsx"

Note: Right-click your file, and select Properties to find the file path.
● Click SAVE.

3. Next, drag and drop the Find Range End (License Not Required) action into the
Main section under Open Workbook.

4. Since the data can change in volume depending on the number of entries, you
will first need to find the last row of data. This action will find the last cell in the
Excel workbook so that you can retrieve all of the data in the next step. The data
always starts from the first row, so the starting cell is static. Complete the
following details for this action:

● Display Name: Find End Cell
● Starting Cell: D1
● Search By: Select Column
● Attribute to Return: Select Ending cell in range
● Operator: Select is stored as
● Target: Select endingCell

5. Lastly, drag and drop the Get Value (License Not Required) action into the
Main section under Find End Cell.

6. This action will get the values between the starting cell and the ending cell
configured above. Complete the following details for this action:

● Display Name: Get Values
● Component Type: Select Range
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● Starting Cell: A1
● Ending Cell: Select Variable, then endingCell
● Specify Header Row: Selected
● Header Row Starting Cell: A1
● Header Row Ending Cell: D1
● Operator: Select is stored as
● Target: Select dataValues

When the Specify Header Row checkbox is selected, the robotic task uses the
column header names from A1 to D1 as the key in the returned value instead of
the default keys, A, B, C, and D.

7. Click SAVE CHANGES.
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Test the Robotic Task

Your robotic task is fully configured. Before you add it to a process model in your
application, test the robotic task to make sure it works as expected.

1. Click TEST.

2. Leave the default settings, and click TEST.
3. You will see green check marks next to the actions once they are complete.
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4. Click dataValues in the right Variables pane to see the saved values from the
Excel workbook.

5. If you do not see the green check marks, open the Execution log to identify the
error. To edit your robotic task, click the Go to robotic task configuration icon

in the top right corner.

Note: A common error is an incorrect file path.
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Configure the Appian Application

The robotic task opens the Excel workbook and retrieves the data. Now we need to
create a process model to execute the robotic task and save the data values to a
database.

In this section you’ll create the following objects in your Appian application:
● Integration
● Process Model

First, create an integration so that you can execute the robotic task from your business
process.

1. Navigate back to the Parse Excel Files Tutorial application.
2. Click NEW > Integration.

● Connected System: RT Appian RPA CS (Appian RPA)
● Operation: Select Execute Robotic Task
● Name: RT_ExecuteExcelFileRoboticTask
● Description: Executes the robotic task for the Parse Excel Files

tutorial to get an excel file and add it to a document folder.
● Click CREATE.

3. Use the following information to configure the integration:
● Robotic Task: RT_ParseExcelFile
● Robot: Leave the First available robot default value
● Description: Executes the Parse Excel Files robotic task
● Priority: Normal
● Parameters: Leave the default values
● Click TEST REQUEST, then SAVE CHANGES.

Next, create the process model.

1. Navigate back to the Parse Excel Files Tutorial application.
2. Click NEW > Process Model.

● Name: RT Get Excel Business Opportunities
● Description: Executes the robotic task and saves the Business

Opportunities data to a database.
● Click CREATE.

3. Review security, and click SAVE.

In this step, you’ll configure the process model to execute the robotic task and save the
values to a database.
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1. Drag and drop an Execute Robotic Task node to the process model. Make sure
the connecting line is highlighted before dropping the node.

2. Rename the node, Execute Parse Excel Robotic Task.
3. Double-click the node, and navigate to the Setup tab.
4. Type and select RT_ExecuteExcelFileRoboticTask in the RPA Integration

field.
5. Navigate to the Data tab.
6. In the Data tab, click the Outputs tab.
7. Select Status.
8. Next to the Target field, click the New process variable icon.

9. Rename the process variable to roboticTaskStatus, and click OK.
10.Select Variables.
11.Repeat step 9 to create another process variable. Complete the following fields:

● Name: roboticTaskVariables
● Type: Map
● Multiple: Selected

12.Click OK.

Next, add a Write to Data Story Entity node to save the values to a database.

1. Drag and drop a Write to Data Store Entity smart service to the process
model after Execute Robotic Task.

2. Double-click the node, and navigate to the Data tab.
3. In the Inputs tab, select Data Store Entity.
4. Next to the Value field, click the Directory icon and search for the data store

you created earlier, RT Excel Data Tutorial DS.
5. Next to businessOpportunities, click Select, then OK.
6. In the Inputs tab, click New Input.
7. Complete the following details for the second input:

● Name: businessOpportunities
● Type: RT_BusinessOpportunities
● Multiple: Selected
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● Value: Open the Expression Editor, and type
=pv!roboticTaskVariables.dataValues

● Click SAVE AND CLOSE.
● Click OK.

8. Click File > Save & Publish.
9. Click File > Start Process for Debugging. You may have to wait and refresh

the process model for it to complete.

10.Once each node turns blue, navigate to the Cloud Database. You should see
the data from the Excel sheet in the table.

Great work! You’ve completed the Parse Excel Files RPA Tutorial. Continue learning with
the next tutorial in the series.
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