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DRAFT KB-XXXX HTTP 503 Service Unreachable with error "Failed opening socket: Connecting to backend failed"

Symptoms

Apache Web Server has been configured to work with Appian. All components of Appian are running successfully. Apache is running successfully.

Trying to reach https://<SITE_URL>/suite fails with HTTP 503 Service Unreachable and the following error in mod_jk.log:

Failed opening socket to (::1:8009) (errno=111) 
connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
connecting to tomcat failed.
service failed, worker node1 is in error state
All tomcat instances are busy or in error state
All tomcat instances failed, no more workers left

Cause

the IP field isn't not configured properly

Action

Ensure that the IP field matches the IP of the web server as mentioned in Configuring Apache Web Server with Appian.

Affected Versions

This article applies to all versions of Appian using Apache as the Web Server.

Last Reviewed: November 2018