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DRAFT KB-3905 Intermittent permission error on record summary after running related actions

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

After navigating to a record from a record tag and launching a related action from a related action shortcut, once the related action completes, users are shown a pink box error instead of being navigated back to the record summary with the following error message:

An Error Has Occurred
The record data does not exist, has been deleted, or you do not have sufficient privileges to access it.

Cause

This issue has been addressed via AN-XXXXX in Appian X.X Hotfix Package X.

  • This issue has been addressed via AN-XXXXX in the following hotfixes/versions:
    • List each specific hotfix package/version in descending order by version.
  • This use case has been incorporated in Appian X.X Hotfix Package X.
  • This use case has been incorporated in the following versions/hotfixes:
    • List each specific hotfix package/version in descending order by version.

Note: When listing hotfixes, add a hyperlink to the Hotfix documentation for that version.

Action

Apply the latest hotfix to your Appian installation for Appian versions 18.2, 18.3, and 18.4 or upgrade to the latest version of Appian for versions 18.1 and earlier.

Affected Versions

This article applies to Appian 18.4 and earlier.

Last Reviewed: March 2020