You are currently reviewing an older revision of this page.

DRAFT KB-XXXX Health Check stuck on the "Analyze Data" stage

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

The Appian Health Check is stuck on the "Analyze Data" stage, typically on the first execution of the Health Check. No errors are printed in the application server logs (tomcat-stdOut.log).

Cause

There is no timeout specified for the HTTP connection to Appian Forum. This issue has been addressed via AN-148308 in Appian 19.4 Hotfix Package C.

Action

Apply the latest hotfix to your Appian installation, or follow the below instructions to unblock the Appian Health Check for on-premise installations:

  1. Connect to the Appian Primary Database.
  2. Run: SELECT * FROM healthcheck;
  3. For any rows that have a fields of status=RUNNING and heartbeat=null, note down the value of the id field.
  4. With the identified id in Step 3, run UPDATE healthcheck set status='FAILED',status_constraint=<ID_OF_STUCK_RUN> where id=<ID_OF_STUCK_RUN>;
  5. Execute the Appian Health Check

To unblock the Appian Health Check for Cloud installations, please contact Appian Support. 

Affected Versions

This article applies to Appian 19.4.

Last Reviewed: April 2020