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DRAFT KB-XXXX Connection closed errors when connecting to Appian Cloud from external resources

Symptoms

Previously functional connections from external resources, such as Web API calls, to Appian Cloud instances start failing with the following exception or a similar one indicating the forceful termination of the connection to Appian:

The underlying connection was closed: An unexpected error occurred on a send.

Cause

This typically indicates that the resource attempting to connect to the Appian Cloud instance is not configured to use TLS 1.1 or higher. Appian is in the process of deprecating TLS 1.0 support in Appian Cloud and Appian Cloud instances will no longer permit connections using TLS 1.0. For more information about Appian's deprecation of TLS 1.0, see KB-1064

Action

Use cURL or a third-party tool such as Postman or SoapUI from the origin server to verify that the connection still works as expected with a client that supports TLS 1.1. If this is the case, update the application code or client version to support TLS 1.1 or higher. Please note that Appian is unable to provide detailed instructions for updating external systems to use TLS 1.1. If you require assistance in making this change, contact the vendor or developer supplying the external system.

Affected Versions

This article applies to Appian Cloud.

Last Reviewed: January 2018