KB-1295 "An unknown error has occurred while saving the process model" thrown when saving a process model
Symptoms
When attempting to save a process model, an error message “An unknown error has occurred while saving the process model” appears and the changes to the process model are not saved:
An unknown error has occurred while saving the process model.
A 500 error can also be observed in the browser capture indicating the request was not successful.
Cause
A 500 error indicates an internal server error; that there is a misconfiguration at the Apache level. This error prevents the request from completing successfully.
Action
For non-production environments: stop Apache. Disable mod_security in httpd.conf on Apache to allow the requests to go through. Restart Apache. Once you confirm the root cause, fix the conflicting mod_security rule.
Caution: Disabling mod_security could potentially be dangerous for some systems. Please confirm with your Web Server Administrator before making any changes. Refer to Apache Docs for more information.
For production environments: make adjustments to the mod_sec rules based on the Apache logs.
Affected Versions
This article applies to all versions of Appian using Apache as a web server.
Last Reviewed: December 2016

