Updating records not working

Certified Senior Developer

Hi all,
We are using record type PVs in our process model and passing the same to user input task. In the task, we are updating the values and after submit is clicked, we are updating the variables to database using write to records smart service. But when we are doing the same, the values are getting updated in pv level, but not getting updated in database. All configurations are correct inside the process model. Not sure what is the gap in this? Please provide your insights.

  Discussion posts and replies are publicly visible

Parents Reply
  • +1
    Certified Senior Developer
    in reply to Abhishek Karumuru

    Sorry for the delay in reply.
    We tried remapping everything and did the changes once more. Still the issue is not resolved. Then we saved the same variable again into the same variable using a script task. Then data was getting updated properly in the database. 
    In 24.1 version, we can see if values of variables are changed using process history. When we checked, the values were changed but in process history, it didn't show that arrow icon which will indicate whether has been changed or not. After saving using script task, that arrow mark appeared and everything was perfect. This issue seems to be a weird one but resaving using script task solved the issue.

    Thanks for helping


No Data