Part Twelve: Start Appian 17.4 and Log In ERROR with Jboss

HI, im tryin to iniciated appian with all the services. but when i run the 

  • <JBOSS_HOME>\bin\standalone.bat get me this error how can i fix it.

my guide is this: https://docs.appian.com/suite/help/17.4/Quick_Start_Installation_Guide_for_Windows_and_JBoss.html#part-ten-deploy-the-configurations

im on the part twelve.

when im going to the browsers show me this.

Thanks fot he help.

  • Hi Jonga,

    Were you able to complete steps 1-11 without any problems? When you completed step 10, were the configurations validated and deployed successfully?

    Can you paste any ERROR and "Caused by:" messages from the application server log?

    Best,
    Jordan
  • Hi thanks for answer, yes everything is fine until step 10.

    sorry i dont understand this question: Can you paste any ERROR and "Caused by:" messages from the application server log?

    im new in this tecnology.

    i think i install the jboss correctly.

  • 3757.server.log

    this is the file there is a lot of things.

    thanks  for help me

  • It seems that JBoss is unable to connect to the Appian data source. This means something likely went wrong in Part 5, Part 7, or Part 8 of the guide.

    First, please ensure the following things:
    1. All references to the Appian primary datasource exactly match the name of the database created in MySQL.
    2. The user running Appian has full permission to access this database in MySQL.
    3. The username and password given in Part 8 match the credentials used to log in to MySQL.
    4. The module.xml file and MySQL driver are in the correct directory and have the correct contents (C:\appian174\appian\bin\jboss\jboss-eap-6.4\modules\com\mysql\jdbc\main)

    In addition, whenever JBoss fails, it is necessary to rename the following files before restarting to make sure the extension is .dodeploy (rather than .failed or .undeployed):
    1. C:\appian174\appian\ear\suite.ear.dodeploy
    2. C:\appian174\appian\bin\jboss\jboss-eap-6.4\standalone\deployments\appian-mysql-ds.xml.dodeploy
  • In order for Appian to run, it is required to configure a relational database as the primary datasource. More information on this can be found here: docs.appian.com/.../Enterprise_Architecture_Overview.html

    This database must be configured using MySQL, SQL Server, or Oracle. Instructions on how to create this database can be found here docs.appian.com/.../Quick_Start_Installation_Guide_for_Windows_and_JBoss.html in the "Install and Setup MySQL Workbench" section. The name of the database you made is referenced in the XML files throughout the Installation Guide (specifically Part 5). Please ensure that the references to this database exactly match the name you gave it in MySQL Workbench.
  • Hey,

    Read through the post in paranthesis that I made for another user. I did like 49 replies to this post and its intense and addresses almost everything you can go wrong. The main reason why you are failing is because jboss is unable to communicate with the database.(community.appian.com/.../local-machine-installation-without-fqdn-and-error-with-starting-up-a-local-demo-installation)

    1. Check if you installed the correct drivers in jboss with the appropriate folder level as mentioned on forum.

    2. Check if you have given previleges to the user account you are using to connect to the database. You can do it using the following sql commands:

    grant all on appian174_primary.* to user@localhost;

    grant all on appian174_business.* to user@localhost;

    3. If using MySQL check if mysql services are running under Services in Windows.

    4. Use appian-ds.xml in

    1300.appian-ds.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <datasources xmlns="www.jboss.org/.../schema">
    <xa-datasource
    jndi-name="jdbc/AppianPrimaryDS"
    pool-name="MySqlDS"
    enabled="true"
    use-java-context="false">
    <xa-datasource-property name="serverName">localhost</xa-datasource-property>
    <xa-datasource-property name="portNumber">3306</xa-datasource-property>
    <xa-datasource-property name="databaseName">appian174_primary</xa-datasource-property>
    <xa-datasource-property name="useUnicode">true</xa-datasource-property>
    <xa-datasource-property name="characterEncoding">UTF-8</xa-datasource-property>
    <xa-datasource-class>com.mysql.jdbc.jdbc2.optional.MysqlXADataSource</xa-datasource-class>
    <driver>com.mysql.jdbc</driver>
    <security>
    <security-domain>ds-name-security-primary</security-domain>
    </security>
    <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>
    <xa-pool>
    <min-pool-size>5</min-pool-size>
    <max-pool-size>100</max-pool-size>
    </xa-pool>
    <timeout>
    <blocking-timeout-millis>5000</blocking-timeout-millis>
    <idle-timeout-minutes>5</idle-timeout-minutes>
    </timeout>
    </xa-datasource>
    <xa-datasource
    jndi-name="jdbc/AppianBusinessDS"
    pool-name="MySqlDS"
    enabled="true"
    use-java-context="false">
    <xa-datasource-property name="serverName">localhost</xa-datasource-property>
    <xa-datasource-property name="portNumber">3306</xa-datasource-property>
    <xa-datasource-property name="databaseName">appian174_business</xa-datasource-property>
    <xa-datasource-property name="useUnicode">true</xa-datasource-property>
    <xa-datasource-property name="characterEncoding">UTF-8</xa-datasource-property>
    <xa-datasource-class>com.mysql.jdbc.jdbc2.optional.MysqlXADataSource</xa-datasource-class>
    <driver>com.mysql.jdbc</driver>
    <security>
    <security-domain>ds-name-security-business</security-domain>
    </security>
    <transaction-isolation>TRANSACTION_READ_COMMITTED</transaction-isolation>
    <xa-pool>
    <min-pool-size>5</min-pool-size>
    <max-pool-size>100</max-pool-size>
    </xa-pool>
    <timeout>
    <blocking-timeout-millis>5000</blocking-timeout-millis>
    <idle-timeout-minutes>5</idle-timeout-minutes>
    </timeout>
    </xa-datasource>
    </datasources>
    
     the format I have attached below. Do not use the format given on forum(it sometimes work and sometimes doesn't). 

    5. Check your standalone.xml file. Follow the format I have attached. Just change the username and password under security-domains for primary and secondary dbs to fit to yours. Use the config.bat file to get the encrypted password.

     

    2742.standalone.xml
    <?xml version='1.0' encoding='UTF-8'?>
    
    <server xmlns="urn:jboss:domain:1.7">
    <extensions>
    <extension module="org.jboss.as.clustering.infinispan"/>
    <extension module="org.jboss.as.connector"/>
    <extension module="org.jboss.as.deployment-scanner"/>
    <extension module="org.jboss.as.ee"/>
    <extension module="org.jboss.as.ejb3"/>
    <extension module="org.jboss.as.jaxrs"/>
    <extension module="org.jboss.as.jdr"/>
    <extension module="org.jboss.as.jmx"/>
    <extension module="org.jboss.as.jpa"/>
    <extension module="org.jboss.as.jsf"/>
    <extension module="org.jboss.as.logging"/>
    <extension module="org.jboss.as.mail"/>
    <extension module="org.jboss.as.messaging"/>
    <extension module="org.jboss.as.naming"/>
    <extension module="org.jboss.as.pojo"/>
    <extension module="org.jboss.as.remoting"/>
    <extension module="org.jboss.as.sar"/>
    <extension module="org.jboss.as.security"/>
    <extension module="org.jboss.as.threads"/>
    <extension module="org.jboss.as.transactions"/>
    <extension module="org.jboss.as.web"/>
    <extension module="org.jboss.as.webservices"/>
    <extension module="org.jboss.as.weld"/>
    </extensions>
    <system-properties>
    <property name="org.apache.tomcat.util.http.Parameters.MAX_COUNT" value="5000"/>
    </system-properties>
    <management>
    <security-realms>
    <security-realm name="ManagementRealm">
    <authentication>
    <local default-user="$local" skip-group-loading="true"/>
    <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
    </authentication>
    <authorization map-groups-to-roles="false">
    <properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>
    </authorization>
    </security-realm>
    <security-realm name="ApplicationRealm">
    <authentication>
    <local default-user="$local" allowed-users="*" skip-group-loading="true"/>
    <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
    </authentication>
    <authorization>
    <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
    </authorization>
    </security-realm>
    </security-realms>
    <audit-log>
    <formatters>
    <json-formatter name="json-formatter"/>
    </formatters>
    <handlers>
    <file-handler name="file" formatter="json-formatter" relative-to="jboss.server.data.dir" path="audit-log.log"/>
    </handlers>
    <logger log-boot="true" log-read-only="false" enabled="false">
    <handlers>
    <handler name="file"/>
    </handlers>
    </logger>
    </audit-log>
    <management-interfaces>
    <native-interface security-realm="ManagementRealm">
    <socket-binding native="management-native"/>
    </native-interface>
    <http-interface security-realm="ManagementRealm">
    <socket-binding http="management-http"/>
    </http-interface>
    </management-interfaces>
    <access-control provider="simple">
    <role-mapping>
    <role name="SuperUser">
    <include>
    <user name="$local"/>
    </include>
    </role>
    </role-mapping>
    </access-control>
    </management>
    <profile>
    <subsystem xmlns="urn:jboss:domain:messaging:1.1">
    <hornetq-server>
    <persistence-enabled>true</persistence-enabled>
    <security-domain>messaging</security-domain>
    <journal-file-size>102400</journal-file-size>
    <journal-min-files>2</journal-min-files>
    
    <connectors>
    <netty-connector name="netty" socket-binding="messaging"/>
    <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
    <param key="batch-delay" value="50"/>
    </netty-connector>
    <in-vm-connector name="in-vm" server-id="0"/>
    </connectors>
    
    <acceptors>
    <netty-acceptor name="netty" socket-binding="messaging"/>
    <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
    <param key="batch-delay" value="50"/>
    <param key="direct-deliver" value="false"/>
    </netty-acceptor>
    <in-vm-acceptor name="in-vm" server-id="0"/>
    </acceptors>
    
    <broadcast-groups>
    <broadcast-group name="appian-broadcast-group">
    <socket-binding>messaging-group</socket-binding>
    <broadcast-period>5000</broadcast-period>
    <connector-ref>
    netty
    </connector-ref>
    </broadcast-group>
    </broadcast-groups>
    
    <discovery-groups>
    <discovery-group name="appian-discovery-group">
    <socket-binding>messaging-group</socket-binding>
    <refresh-timeout>10000</refresh-timeout>
    </discovery-group>
    </discovery-groups>
    
    <security-settings>
    <security-setting match="#">
    <permission type="send" roles="guest"/>
    <permission type="consume" roles="guest"/>
    </security-setting>
    </security-settings>
    
    <address-settings>
    <address-setting match="#">
    <dead-letter-address>jms.queue.DLQ</dead-letter-address>
    <expiry-address>jms.queue.ExpiryQueue</expiry-address>
    <redelivery-delay>0</redelivery-delay>
    <max-size-bytes>10485760</max-size-bytes>
    <address-full-policy>BLOCK</address-full-policy>
    <message-counter-history-day-limit>10</message-counter-history-day-limit>
    </address-setting>
    </address-settings>
    
    <jms-connection-factories>
    <connection-factory name="ProcessIntegrationConnectionFactory">
    <connectors>
    <connector-ref connector-name="netty"/>
    </connectors>
    <entries>
    <entry name="jms/AppianProcessIntegrationConnectionFactory"/>
    <entry name="java:jboss/exported/jms/AppianProcessIntegrationConnectionFactory"/>
    </entries>
    </connection-factory>
    <pooled-connection-factory name="hornetq-ra">
    <transaction mode="xa"/>
    <connectors>
    <connector-ref connector-name="in-vm"/>
    </connectors>
    <entries>
    <entry name="java:/JmsXA"/>
    </entries>
    </pooled-connection-factory>
    </jms-connection-factories>
    
    <jms-destinations>
    <jms-queue name="jms/ProcessQueue">
    <entry name="jms/AppianProcessIntegrationQueue"/>
    <entry name="java:jboss/exported/jms/AppianProcessIntegrationQueue"/>
    </jms-queue>
    </jms-destinations>
    
    </hornetq-server>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:logging:1.5">
    <console-handler name="CONSOLE">
    <level name="INFO"/>
    <formatter>
    <named-formatter name="COLOR-PATTERN"/>
    </formatter>
    </console-handler>
    <periodic-rotating-file-handler name="FILE" autoflush="true">
    <formatter>
    <named-formatter name="PATTERN"/>
    </formatter>
    <file relative-to="jboss.server.log.dir" path="server.log"/>
    <suffix value=".yyyy-MM-dd"/>
    <append value="true"/>
    </periodic-rotating-file-handler>
    <logger category="com.arjuna">
    <level name="WARN"/>
    </logger>
    <logger category="org.apache.tomcat.util.modeler">
    <level name="WARN"/>
    </logger>
    <logger category="org.jboss.as.config">
    <level name="DEBUG"/>
    </logger>
    <logger category="sun.rmi">
    <level name="WARN"/>
    </logger>
    <logger category="jacorb">
    <level name="WARN"/>
    </logger>
    <logger category="jacorb.config">
    <level name="ERROR"/>
    </logger>
    <logger category="org.jboss.as.server.deployment"> <!-- Added this element -->
    <level name="ERROR"/>
    </logger>
    <root-logger>
    <level name="INFO"/>
    <handlers>
    <handler name="CONSOLE"/>
    <handler name="FILE"/>
    </handlers>
    </root-logger>
    <formatter name="PATTERN">
    <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
    </formatter>
    <formatter name="COLOR-PATTERN">
    <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
    </formatter>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:datasources:1.2">
    <datasources>
    <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
    <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1;DB_CLOSE_ON_EXIT=FALSE</connection-url>
    <driver>h2</driver>
    <security>
    <user-name>sa</user-name>
    <password>sa</password>
    </security>
    </datasource>
    <drivers>
    <driver name="h2" module="com.h2database.h2">
    <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
    </driver>
    <driver name="com.mysql.jdbc" module="com.mysql.jdbc">
    <driver-class>com.mysql.jdbc.Driver</driver-class>
    <xa-datasource-class>com.mysql.jdbc.jdbc2.optional.MysqlXADataSource</xa-datasource-class>
    </driver>
    <!--
    <driver name="oracle.jdbc" module="oracle.jdbc">
    <xa-datasource-class>oracle.jdbc.xa.client.OracleXADataSource</xa-datasource-class>
    </driver>
    <driver name="com.microsoft.sqlserver.jdbc" module="com.microsoft.sqlserver.jdbc">
    <xa-datasource-class>com.microsoft.sqlserver.jdbc.SQLServerXADataSource</xa-datasource-class>
    </driver>
    <driver name="com.ibm.db2.jcc" module="com.ibm.db2.jcc">
    <xa-datasource-class>com.ibm.db2.jcc.DB2Driver</xa-datasource-class>
    </driver>
    -->
    </drivers>
    </datasources>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
    <deployment-scanner name="appian" path="${appian.home.ear}" auto-deploy-exploded="false" auto-deploy-zipped="false" auto-deploy-xml="false" deployment-timeout="3600" scan-interval="5000"/>
    <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:ee:1.2">
    <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
    <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
    <annotation-property-replacement>false</annotation-property-replacement>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:ejb3:1.5">
    <mdb>
    <resource-adapter-ref resource-adapter-name="hornetq-ra"/>
    <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>
    </mdb>
    <session-bean>
    <stateless>
    <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
    </stateless>
    <stateful default-access-timeout="5000" cache-ref="simple"/>
    <singleton default-access-timeout="5000"/>
    </session-bean>
    <pools>
    <bean-instance-pools>
    <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
    <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
    <strict-max-pool name="UnattendedRequestPool" max-pool-size="30" instance-acquisition-timeout="15" instance-acquisition-timeout-unit="MINUTES"/>
    </bean-instance-pools>
    </pools>
    <caches>
    <cache name="simple" aliases="NoPassivationCache"/>
    <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>
    </caches>
    <passivation-stores>
    <file-passivation-store name="file"/>
    </passivation-stores>
    <async thread-pool-name="default"/>
    <timer-service thread-pool-name="default" default-data-store="default-file-store">
    <data-stores>
    <file-data-store name="default-file-store" path="timer-service-data" relative-to="jboss.server.data.dir"/>
    </data-stores>
    </timer-service>
    <remote connector-ref="remoting-connector" thread-pool-name="default"/>
    <thread-pools>
    <thread-pool name="default">
    <max-threads count="10"/>
    <keepalive-time time="100" unit="milliseconds"/>
    </thread-pool>
    </thread-pools>
    <default-security-domain value="other"/>
    <default-missing-method-permissions-deny-access value="true"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:infinispan:1.5">
    <cache-container name="web" aliases="standard-session-cache" default-cache="local-web" module="org.jboss.as.clustering.web.infinispan">
    <local-cache name="local-web" batching="true">
    <file-store passivation="false" purge="false"/>
    </local-cache>
    </cache-container>
    <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">
    <local-cache name="entity">
    <transaction mode="NON_XA"/>
    <eviction strategy="LRU" max-entries="10000"/>
    <expiration max-idle="100000"/>
    </local-cache>
    <local-cache name="local-query">
    <transaction mode="NONE"/>
    <eviction strategy="LRU" max-entries="10000"/>
    <expiration max-idle="100000"/>
    </local-cache>
    <local-cache name="timestamps">
    <transaction mode="NONE"/>
    <eviction strategy="NONE"/>
    </local-cache>
    </cache-container>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
    <subsystem xmlns="urn:jboss:domain:jca:1.1">
    <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
    <bean-validation enabled="true"/>
    <default-workmanager>
    <short-running-threads>
    <core-threads count="50"/>
    <queue-length count="50"/>
    <max-threads count="50"/>
    <keepalive-time time="10" unit="seconds"/>
    </short-running-threads>
    <long-running-threads>
    <core-threads count="50"/>
    <queue-length count="50"/>
    <max-threads count="50"/>
    <keepalive-time time="10" unit="seconds"/>
    </long-running-threads>
    </default-workmanager>
    <cached-connection-manager/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
    <subsystem xmlns="urn:jboss:domain:jmx:1.3">
    <expose-resolved-model/>
    <expose-expression-model/>
    <remoting-connector/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:jpa:1.1">
    <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
    <subsystem xmlns="urn:jboss:domain:mail:1.2">
    <mail-session name="default" jndi-name="java:jboss/mail/Default">
    <smtp-server outbound-socket-binding-ref="mail-smtp"/>
    </mail-session>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:naming:1.4">
    <remote-naming/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>
    <subsystem xmlns="urn:jboss:domain:remoting:1.2">
    <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>
    <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
    <subsystem xmlns="urn:jboss:domain:security:1.2">
    <security-domains>
    <security-domain name="other" cache-type="default">
    <authentication>
    <login-module code="Remoting" flag="optional">
    <module-option name="password-stacking" value="useFirstPass"/>
    </login-module>
    <login-module code="RealmDirect" flag="required">
    <module-option name="password-stacking" value="useFirstPass"/>
    </login-module>
    </authentication>
    </security-domain>
    <security-domain name="jboss-web-policy" cache-type="default">
    <authorization>
    <policy-module code="Delegating" flag="required"/>
    </authorization>
    </security-domain>
    <security-domain name="jboss-ejb-policy" cache-type="default">
    <authorization>
    <policy-module code="Delegating" flag="required"/>
    </authorization>
    </security-domain>
    <security-domain name="messaging" cache-type="default">
    <authentication>
    <login-module code="RealmUsersRoles" flag="required">
    <module-option name="unauthenticatedIdentity" value="guest"/>
    <module-option name="usersProperties" value="${jboss.server.config.dir}/application-users.properties"/>
    <module-option name="rolesProperties" value="${jboss.server.config.dir}/application-roles.properties"/>
    </login-module>
    </authentication>
    </security-domain>
    <security-domain name="ds-name-security-primary" cache-type="default">
    <authentication>
    <login-module code="org.picketbox.datasource.security.SecureIdentityLoginModule" flag="required">
    <module-option name="username" value="root" />
    <module-option name="password" value="******************" />
    </login-module>
    </authentication>
    </security-domain>
    <security-domain name="ds-name-security-business" cache-type="default">
    <authentication>
    <login-module code="org.picketbox.datasource.security.SecureIdentityLoginModule" flag="required">
    <module-option name="username" value="root" />
    <module-option name="password" value="**********************" />
    </login-module>
    </authentication>
    </security-domain>
    </security-domains>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
    <subsystem xmlns="urn:jboss:domain:transactions:1.5">
    <core-environment>
    <process-id>
    <uuid/>
    </process-id>
    </core-environment>
    <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
    <coordinator-environment default-timeout="300"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:web:2.2" default-virtual-server="default-host" native="false">
    <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
    <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>
    <virtual-server name="default-host" enable-welcome-root="true">
    <alias name="localhost"/>
    <alias name="example.com"/>
    </virtual-server>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:webservices:1.2">
    <modify-wsdl-address>true</modify-wsdl-address>
    <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
    <endpoint-config name="Standard-Endpoint-Config"/>
    <endpoint-config name="Recording-Endpoint-Config">
    <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
    <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
    </pre-handler-chain>
    </endpoint-config>
    <client-config name="Standard-Client-Config"/>
    </subsystem>
    <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
    </profile>
    <interfaces>
    <interface name="management">
    <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
    </interface>
    <interface name="public">
    <inet-address value="${jboss.bind.address:0.0.0.0}"/>
    </interface>
    <!-- TODO - only show this if the jacorb subsystem is added -->
    <interface name="unsecure">
    <!--
    ~ Used for IIOP sockets in the standard configuration.
    ~ To secure JacORB you need to setup SSL
    -->
    <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
    </interface>
    </interfaces>
    <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
    <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
    <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
    <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
    <socket-binding name="ajp" port="8009"/>
    <socket-binding name="http" port="8080"/>
    <socket-binding name="https" port="8443"/>
    <socket-binding name="remoting" port="4447"/>
    <socket-binding name="txn-recovery-environment" port="4712"/>
    <socket-binding name="txn-status-manager" port="4713"/>
    <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:233.252.134.134}" multicast-port="${jboss.messaging.group.port:9876}"/>
    <socket-binding name="messaging" port="5445"/>
    <socket-binding name="messaging-throughput" port="5455"/>
    <outbound-socket-binding name="mail-smtp">
    <remote-destination host="localhost" port="25"/>
    </outbound-socket-binding>
    </socket-binding-group>
    </server>
    

  • docs.appian.com/.../Quick_Start_Installation_Guide_for_Windows_and_JBoss.html

    According to the error log, I feel its the SQL Driver Missing. Kindly follow the above link to proceed.

 Discussion posts and replies are publicly visible