Update process variable at runtime

Hi,

I have a node where I want to update process variable at runtime.

This is the expression I have written

a!save(pv!Schedule_1_Temp_Value,pv!Schedule_1_Temp_Value + 1)

but, I am getting this page (below) when I run this process model in debug mode.

  Discussion posts and replies are publicly visible

Parents
  • There's likely two problems here. First, you can only use a!save() in an interface. If you want to save into a process variable, you should use a script task and add a Data > Output. Using the output you can create any expression and save the results into a process variable. The second issue is that whatever node you're using doesn't have the correct kind of form. If you truly are just updating a process variable directly, you shouldn't have a form at all.

    If you still have questions, can you provide more information about your configuration? Where did you configure that expression? What does your process do? Can you share screenshots of what you configured?

  • Hi ,

    Actually, I am using MS Word 2007 Doc From Template smart service. At one of its tag (i.e Schedule_1) I and trying to writer expression which can dynamically update process variable so that each time the control comes at that tag it gets updated value from process variable which I am trying to update dynamically.

    MS Word 2007 Doc From Template :

    Schedule_1 tag expression editor :

Reply
  • Hi ,

    Actually, I am using MS Word 2007 Doc From Template smart service. At one of its tag (i.e Schedule_1) I and trying to writer expression which can dynamically update process variable so that each time the control comes at that tag it gets updated value from process variable which I am trying to update dynamically.

    MS Word 2007 Doc From Template :

    Schedule_1 tag expression editor :

Children