Developer Developer course: Email problem

Certified Associate Developer

Hi there,

I'm working on the "Appian Developer Project: Build an IT Application" component at the end of the course and I've run into a problem with sending email from the Update Request process model.

The send email fails with the error "No valid recipients resolved". It appears that after the Write Records, the full record isn't being transferred to the Send Email. I've verified that the record IS being updated. As far as I can tell, my code mimics the AIS solution.

This is the result from my process:

and this is the result from the AIS process:

As you can see, in the AIS version, the record contents after the Write Records is full, whereas mine only shows "id=3".

One difference I noted between the two is that mine uses a newer version of the Write Records. The "Configure Write Records" dialog has a Setup menu:

I modified the AIS solution to use the new version and it worked with no issues, so that doesn't seem to be a factor.

I'm at a real loss trying to figure this out. My Request record and save settings for the Update Request interrace appear to be the same as the AIS solution. Does anyone have any ideas where my problem might be?



  Discussion posts and replies are publicly visible

  • +1
    Certified Senior Developer

    Hi  ,

    Write Records output in 23.3

    Write records output in 23.2

    As you can see the above images, The write records has been updated. Which is the reason you are getting the above result. As far as the AIS one is concerned, if you open the record, it will give you a prompt to update the record like below image

    If you click on update now, it will be acting as the new version. 

    So for newer records, the solution is to query the records using the ids we get in the output (ac!recordsUpdated) and save the output in our variables.

  • 0
    Certified Associate Developer
    in reply to Sri Ram Kaja

    Once I figured out that I didn't have to create a process variable because there already was one, it worked!

    Looks like Appian needs to update their course content otherwise EVERYONE will run into the same issue.

    Thank you for your help,


Reply Children
No Data