Start Process Smart Service failing though Process Instance is being triggered

I am triggering a Process Instance by using 'Start Process Smart Service'. A weird behavior I have noticed is, the Process Instance is being triggered but the Start Process Smart Service is crashing with an error. The target process model has just two parameters out of which one is of type CDT(single) and other is of type Date (single). I can also clearly see the triggered instances, the parameterised variables in triggered instances populated with values configured in the Start Process Smart Service node.

Content from logs is as follows:
UnattendedJavaActivityRequest] ERROR com.appiancorp.process.engine.UnattendedJavaActivityRequest - An error occurred while executing activity: id=536936184, classname=com.appiancorp.process.runtime.activities.StartProcessSmartService2
12:39:25,568 INFO [stdout] (Appian Work Item - 6406 - Proce...

OriginalPostID-240702

Parents
  • ...ssExec02 : UnattendedJavaActivityRequest) com.appiancorp.suiteapi.process.exceptions.SmartServiceException: userMsg[error.processDetails.userMsg=Error when parsing process details or variables] alertMsg[error.processDetails.alertMsg=Error when parsing process details or variables]

    Though I took care of security, it shouldn't be an issue in any case as I am running the instances as a System Administrator.

    Has anyone come across this issue before?

    From my search, I see that the post at forum.appian.com/.../e-216246 is slightly related to it in terms of behavior (that is, process instance is being run and the node has been failing). There is also another issue at forum.appian.com/.../e-238982 which meantions a failure rate of ~10%. With issues like these, I would like to really question the reliability of this smart service until and unless we are missing something.
Reply
  • ...ssExec02 : UnattendedJavaActivityRequest) com.appiancorp.suiteapi.process.exceptions.SmartServiceException: userMsg[error.processDetails.userMsg=Error when parsing process details or variables] alertMsg[error.processDetails.alertMsg=Error when parsing process details or variables]

    Though I took care of security, it shouldn't be an issue in any case as I am running the instances as a System Administrator.

    Has anyone come across this issue before?

    From my search, I see that the post at forum.appian.com/.../e-216246 is slightly related to it in terms of behavior (that is, process instance is being run and the node has been failing). There is also another issue at forum.appian.com/.../e-238982 which meantions a failure rate of ~10%. With issues like these, I would like to really question the reliability of this smart service until and unless we are missing something.
Children
No Data

 Discussion posts and replies are publicly visible