Task Process Report returning null values when filtered

Hey guys, I experienced a bug whilst working with a task process report. I've managed to find a workaround but I'm still not entirely sure what was the issue/problem.

Background: I have a task report that has ~20 columns, containing data from ~20 Process Models. The process variables used across the PMs are not uniform due to many different people being involved in this project over time. One of the columns contains the model IDs for each task, taken from a variety of process variables from the PMs. I opted to use nested if()'s to check each possible process variables (e.g. pv!model.id) to see whether the value was present or blank. This wasn't ideal but worked fine in retrieving the model ID for each task.

I ran into an issue however when filtering on this column or other columns in the report. I first noticed this when querying the process report in an interface but realised it was an issue in the report directly. When I filtered on this particular column or another column in the report (searching text or integer values) then the correct rows were returned but the contents of the model ID column returned blank. Sometimes this happened for all rows, sometimes only certain rows.

A work around has been to change how I retrieve the data for this column - I no longer use nested if()'s but check particular process variables based on the process model.

Has anyone experienced a similar issue to this or know why this bug came about in the first place? Looks like it has something to do with the if()'s but I'm unsure why.

Thanks!

 Discussion posts and replies are publicly visible