Appian integration with RPA Blue Prism

Hi all,

We are on Appian 19.1 and in the process of integrating Appian with Blue Prism.

We have used Connected System to call Blue Prism by passing the required parameters.

HostName: https:[machine name]:[port number]

User Id:

Password:

We are getting the below error:

Something went wrong. The following error occurred: class.javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

However, We are able to connect to Blue Prism on "http" and it returns response but not with "https". The error also resembles something related to SSL.

Any pointers would be helpful.

Appreciate an early response!!!

Parents
  • SSL refers to Secure Sockets Layer, and its what gets you the S in https.  Unfortunately, this error by itself leaves little to go on.  For some reason, you don't have the connection secured. 

    From what I've gathered this error occurs when you attempt to use https to try to connect to something that's not using https, when you try to securely connect to something that isn't secured.  This would mean the problem is likely from the Blue Prism side.  It's either not using https, it's not on a secured port, or something in the configuration of the connected system is acting like it's not secured, causing this error to happen when you try to connect to it via SSH.

    I wish I could be of more help, but I only have the error message to go on.

Reply
  • SSL refers to Secure Sockets Layer, and its what gets you the S in https.  Unfortunately, this error by itself leaves little to go on.  For some reason, you don't have the connection secured. 

    From what I've gathered this error occurs when you attempt to use https to try to connect to something that's not using https, when you try to securely connect to something that isn't secured.  This would mean the problem is likely from the Blue Prism side.  It's either not using https, it's not on a secured port, or something in the configuration of the connected system is acting like it's not secured, causing this error to happen when you try to connect to it via SSH.

    I wish I could be of more help, but I only have the error message to go on.

Children

 Discussion posts and replies are publicly visible