Execute RPA on Linux terminal

Certified Associate Developer

Does anyone tried to execute a robotic task using a robot installed in a remote linux terminal?

Im trying to execute a simple robotic task that open chrome browser and returns me some data of a webpage, the robot is online on the dashboard but when i try to open the browser it pops the following error: 

 2023-04-18 11:05:07 02s (0h) - Driver could not be initialized: unknown error: Chrome failed to start: exited abnormally. 

  Discussion posts and replies are publicly visible

  • May be an issue with the chrome and chrome driver version mismatch.

    Have you marked the below checkbox in configuration under RPA console settings.

  • 0
    Certified Associate Developer
    in reply to Sanchit Gupta (Xebia)

    Yes I did, it autoinstall the chrome driver on /home/carlos/robotappian/./Jidoka-workspace/6437cc3ad526f6341fa8664b/./ChromeWebDriver/chromedriver

    But when i run the robotic task it crashes. 

    Whole error: 

    [DEBUG] 2023-04-18 11:39:43 07s (0h) - Waiting for condition "Browser initialization", try #5 of #5 [DEBUG] 2023-04-18 11:39:43 07s (0h) - Driver file: /home/carlos/robotappian/./Jidoka-workspace/6437cc3ad526f6341fa8664b/./ChromeWebDriver/chromedriver [DEBUG] 2023-04-18 11:39:43 07s (0h) - Using default module Chrome options [WARN] 2023-04-18 11:39:43 08s (0h) - Driver could not be initialized: unknown error: Chrome failed to start: exited abnormally. (unknown error: DevToolsActivePort file doesn't exist) (The process started from chrome location /usr/bin/google-chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.) Build info: version: 'unknown', revision: 'unknown', time: 'unknown' System info: host: 'azdevops-deployment-749c9cbf4d-thjf8', ip: '', os.name: 'Linux', os.arch: 'amd64', os.version: '', java.version: '11.0.18' Driver info: driver.version: ChromeDriver remote stacktrace: #0 0x560f3a178fe3 <unknown>

  • 0
    Certified Lead Developer
    in reply to carlosp7407

    did you find any solution for this!