PickerfieldCustom not working

A Score Level 1

Since I have been trying to populate custom picker from database I have been getting error:

The interface rule is as follows :

a!localVariables(
  local!pickedcode,
local!Code:rule!SA_getAllSKUCode(),


a!pickerFieldCustom(
      label: "SKU Product Code",
      labelPosition: "ABOVE",
      instructions: "",
      placeholder: "---Type SKU Code ---",
      maxselections: 1,
      suggestFunction: rule!SA_ucArrayPickerFilter(
        filter:_ , 
        labels: index(local!Code), 
        identifiers: index(local!Code)
      ),
      selectedLabels: a!forEach(
        items: ri!SA_SKU.SKUProductCode,
        expression: index(index(local!Code), wherecontains(fv!item, index(local!Code)))
      ),

      value: ri!SA_SKU.SKUProductCode,
      saveInto: ri!SA_SKU.SKUProductCode,
      validations: {}
    ),

do anyone know the reason behind this error as I am not able to find much information on it.

Thanks in Advance..

The suggest function used here is:

   index(
    index(a!queryEntity(
    entity:cons!SA_DSE_SKUProduct,
    query: a!query(
      selection: a!querySelection(
        columns: a!queryColumn(
          field:"SKUProductCode"
        )
      ),
      
      filter: a!queryFilter(
        field: "SKUProductCode",
        operator: "<>",
        value: " "
        ),
 pagingInfo: a!pagingInfo(
        startIndex: 1,
        batchSize: -1,
        sort: a!sortInfo(
          field: "SKUProductCode"
        )
      )
      
      )
      
    ),"data",""),"SKUProductCode","")

The ER: 

 Discussion posts and replies are publicly visible