KB-1004 "Premature end of file" error returned during application server startup
| This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian. |
Symptoms
Application server fails to start during the deployment of Appian. The logs indicate a parse exception due to Premature end of file.
The following error message appears in the logs:
ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/suite]] (ServerService Thread Pool -- 70) JBWEB000287: Exception sending context initialized event to listener instance of class com.appiancorp.common.config.ConfigurationLoader: java.lang.ExceptionInInitializerError
at com.appiancorp.process.security.InitializeAdministrator.finish(InitializeAdministrator.java:68) [appian-process.jar:]
at com.appiancorp.common.config.ConfigObject.init(ConfigObject.java:65) [appian-common.jar:]
at com.appiancorp.common.config.ConfigObjectRepository.initConfigObject(ConfigObjectRepository.java:372) [appian-common.jar:]
at com.appiancorp.common.config.ConfigObjectRepository.initConfigObject(ConfigObjectRepository.java:263) [appian-common.jar:]
at com.appiancorp.common.config.ConfigObjectRepository.init(ConfigObjectRepository.java:223) [appian-common.jar:]
at com.appiancorp.common.config.ConfigObjectRepository.create(ConfigObjectRepository.java:95) [appian-common.jar:]
at com.appiancorp.common.config.ConfigObjectRepository.create(ConfigObjectRepository.java:89) [appian-common.jar:]
at com.appiancorp.common.config.ConfigurationLoader.contextInitialized(ConfigurationLoader.java:47) [appian-common.jar:]
at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3339) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
at org.apache.catalina.core.StandardContext.start(StandardContext.java:3780) [jbossweb-7.5.7.Final-redhat-1.jar:7.5.7.Final-redhat-1]
at org.jboss.as.web.deployment.WebDeploymentService.doStart(WebDeploymentService.java:163) [jboss-as-web-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
at org.jboss.as.web.deployment.WebDeploymentService.access$000(WebDeploymentService.java:61) [jboss-as-web-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
at org.jboss.as.web.deployment.WebDeploymentService$1.run(WebDeploymentService.java:96) [jboss-as-web-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_51]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_51]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_51]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_51]
at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]
at org.jboss.threads.JBossThread.run(JBossThread.java:122)
Caused by: java.lang.RuntimeException: java.lang.RuntimeException: javax.xml.bind.UnmarshalException
- with linked exception:
[org.xml.sax.SAXParseException; Premature end of file.]
Cause
As part of running the configure script, there will be appian-topology.xml files generated in <APPIAN_HOME>/ear/suite.ear/conf and <APPIAN_HOME>/search-server/conf. These files are copies of the appian-topology.xml.example file. The default configuration is commented out within this example file. This causes the appian-topology.xml files to be created without the proper configuration.
Action
This issue has been corrected in Appian 7.9 Hotfix Package B. Please apply the latest cumulative hotfix package to resolve this issue.
Workaround
Use either of the following options:
- Remove the appian-topology.xml files from
<APPIAN_HOME>/ear/suite.ear/confand<APPIAN_HOME>/search-server/confto use the default topology configuration. - Modify the files to include the desired engine and search server configuration.
Affected Versions
This article applies to Appian 7.9.
Last Reviewed: February 2017
