KB-1602 News posts missing in Tempo

Symptoms

News posts before a specific date have disappeared from Tempo.

Cause

News posts are stored in the Appian primary data source in the 'tp_feed_entry' table. These posts are indexed for quick retrieval. If these indices become corrupt, indexing must restart, which causes only new entries to be stored and displayed in Tempo. The following sections explain how the posts are indexed based on the Appian version:

Appian 17.1

These news posts are indexed purely by the Apache Lucene software. The indices are stored in the <APPIAN_HOME>\_admin\search-local\index-primary directory.

Appian 17.2 and Later

  • These news posts are not purely indexed by Appian Lucene. Starting with Appian 17.2, the search server began to assume the role of indexing. This is why the <APPIAN_HOME>\_admin\search-local directory in 17.2 contains both the index-primary and search-server folders.
  • Starting with Appian 17.3, these news posts are purely indexed by the search server. The index files are stored in the <APPIAN_HOME>\_admin\search-local\search-server\data\appian-search-cluster\nodes\0\indices directory.
  • If search server experiences an issue (i.e. crashes due to network issue or runs out of disk space), the indices may become corrupt.
  • The root cause of the search server crash can be determined by examining the logs located at <APPIAN_HOME>\logs\search-server.

Action

  1. Confirm the environment is pointing to the correct primary data source. 
  2. Once confirmed, connect to the primary data source and run the following query: SELECT * FROM tp_feed_entry ORDER BY id ASC;
  3. Inspect the content returned by the query. If the content contains old news posts (that are currently missing from Tempo), proceed to the next step.
  4. Recreate the search server indices. Resetting the search server indices can resolve a number of other issues. See KB-1082 for more symptoms regarding issues related to the search server indices, as well as steps on how to perform the reset.

WARNING: These steps should be performed outside of business hours to avoid any potential performance impact.

Affected Versions

This article applies to Appian 17.1 and later.

Last Reviewed: August 2020

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