KB-1690 Users unable to login using Appian authentication after upgrade

Symptoms

After an Appian upgrade, users are unable to log into the environment when using basic Appian authentication.

The db_PE**.log file located in <APPIAN_HOME>\logs should have entries of the following type, indicating the engine migration was successful: 

[PE1] {ag3.kdb 0} (Base) INFO .migrate "<PERCENTAGE OF MIGRATION>% Migrating from version: <APPIAN VERSION>"

However these entries are missing in this log file, which indicates that the <APPIAN_HOME>\server\personalization\gw1\ag**.kdb file was not migrated properly during the upgrade.

Cause

Personalization engine KDB file was not properly copied over during the migration.

Action

Perform the upgrade again and ensure that all KDB files are properly copied during the migration. The Copy Your Engine Data section of the Upgrade Guide explains the proper way to migrate engine data during an Appian upgrade.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: September 2018

Related
Recommended