KB-1962 /suite page keeps loading indefinitely with HTTP 302 status code observed in the network capture after an upgrade

Symptoms

After the username/password are entered on the login screen, the page keeps reloading indefinitely with no result and HTTP status code 302 - Moved Temporarily seen repeating in the network capture.

Cause

Customers may have a web server redirect in place to redirect users to the Appian login page if they doe not type the entire site URL. For IIS specifically, more details on one approach to achieve this redirection can be found in step 17 of the Configuring IIS with Appian documentation. This redirect can also be achieved in a similar manner with Apache or another web server.

Action

If a custom HTML file is being used, copy the HTML file with the redirect to the right location as described in the documentation above. If the redirect was set up using a different approach, engage the web server administrator for the environment to investigate further.

As a general note, customers are encouraged to maintain all customizations via versioning tools and are required to merge the customizations during every upgrade as mentioned here.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: June 2019

Related
Recommended