KB-1731 Engines fail to start after upgrade with “ShaMismatchException” or "EngineReplayException"

Symptoms

Following an upgrade, the Appian Engines fail to start successfully. One of the following errors are also observed in the service_manager.log

K sha256 was <sha>, but the transaction log sha was <sha>
ERROR com.appian.komodo.engine.status.ReplayStateProvider - Error replaying transactions for <engine>: 
TransactionReplayFailedEvent{createdInstant=engineId=<engine>, startTransactionId=Optional[0], transactionsReplayedCount=***,
cause=com.appian.komodo.engine.EngineReplayException: Replaying request with transaction id *** did not result in an update},
caused by: com.appian.komodo.engine.EngineReplayException: Replaying request with transaction id *** did not result in an update

Cause

Engine(s) were improperly shut down before upgrading and there are transactions that have not been checkpointed. Attempting to proceed with an upgrade can result in silent data corruption.

Action

  1. Restore the site to a backup from prior to the upgrade.
  2. Perform a clean shutdown as documented in the Update Guide.
  3. Ensure that there are no checkpointing errors in the service_manager.log. See KB-2068 for detailed information on how to understand checkpointing in the logs.
  4. Re-attempt the upgrade.

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: January 2022

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