KB-1731 Engines fail to start after upgrade with “ShaMismatchException” or "EngineReplayException"

Symptoms

Following an upgrade, the Appian Engines fail to start successfully. One of the following errors are also observed in the service_manager.log

K sha256 was <sha>, but the transaction log sha was <sha>
ERROR com.appian.komodo.engine.status.ReplayStateProvider - Error replaying transactions for <engine>: 
TransactionReplayFailedEvent{createdInstant=engineId=<engine>, startTransactionId=Optional[0], transactionsReplayedCount=***,
cause=com.appian.komodo.engine.EngineReplayException: Replaying request with transaction id *** did not result in an update},
caused by: com.appian.komodo.engine.EngineReplayException: Replaying request with transaction id *** did not result in an update

Cause

Engine(s) were improperly shut down before upgrading and there are transactions that have not been checkpointed. Attempting to proceed with an upgrade can result in silent data corruption.

An Appian on Kubernetes (AoK) site can encounter this issue if the Service Manager finalizer is removed during the site shutdown prior to the upgrade.

Action

Self-Managed Appian

  1. Restore the site to a backup from prior to the upgrade.
  2. Perform a clean shutdown as documented in the Update Guide.
  3. Ensure that there are no checkpointing errors in the service_manager.log. See KB-2068 for detailed information on how to understand checkpointing in the logs.
  4. Re-attempt the upgrade.

Appian on Kubernetes

  1. Stop the site by deleting the Appian CR. Since the Service Manager pods will be unable to start, deleting the CR will require removing the Service Manager finalizer as well.
  2. Change the Appian version in the Appian CRD back to the Appian version prior to the upgrade.
    1. Note that if your CRD specifies a tag for component images as well, the tags must also be updated.
  3. Start the site back up. Some components may not come up successfully, but this is expected. Wait until all of the Service Manager pods are in a Ready state.
  4. Re-attempt the upgrade. Do NOT remove the Service Manager finalizer while shutting the site down.

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: August 2025

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