KB-1748 SAML users frequently logged out of Appian for Mobile Devices with "Your session has expired. Please sign in again." pop up message

This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian.

Symptoms

After answering a phone call or switching to another app, users using SAML authentication with the Appian mobile applications for iOS and Android frequently see the below message and are prompted to re-enter their sign-in credentials.

Cause

This issue has been resolved in the 18.3.1 release of the Appian for Mobile Devices application, which is available in the platform-specific application stores:

Action

  • Update the Appian for Mobile Devices application to the latest available version from the relevant application store listed above.
  • If a centrally controlled mobile device management solution is used to control devices within the organization, push the latest release to the managed devices.
  • If you are currently using a custom mobile application, submit a support case on Appian Community to request the latest build version.

Workaround

If updating the application is not possible, you may replace SAML authentication with either Appian authentication or LDAP authentication to prevent the issue from occurring.

Affected Versions

This article applies to Appian for Mobile Devices versions 18.3 and earlier for both iOS and Android.

Last Reviewed: October 2018

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