KB-1756 Plugin fails to deploy with "Cannot open JAR file for reading" error in app server log

Symptoms

A plugin fails to deploy, and the application server log shows the following error:

[Appian Plugin Hot Deploy] ERROR com.appiancorp.plugins.LoggingPluginEventListener - Failed to load Plug-in '<Plugin Name>.jar' (<Plugin Name>.jar) version 0.0: 'Cannot open JAR file for reading: <Path to plugin>/<Plugin name>.jar'

Cause

The above error is caused by one of the following:

  1. The plugin does not have the correct permissions or ownership to be executed by the user running Appian.
  2. The plugin files are corrupt.

Action

Based on the determined cause above, proceed with one of the following actions, respectively:

  1. Ensure that the plugin has plugin the correct permissions and ownership to be executed by the user running Appian.
  2. Redeploy the original plugin into Appian.
    • If deploying fails again, the plugin may still be corrupt. Rebuild the plugin JAR and redeploy to resolve.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: October 2018

Related
Recommended