KB-1755 Service manager fails to start with "java.lang.UnsatisfiedLinkError - There is not enough space on the disk"

Symptoms

Service manager fails to start with the following error seen in the command line:

Exception in thread "main" java.lang.UnsatisfiedLinkError: Could not load library. Reasons: [no jansi64-1.11 in java.library.path, no jansi-1.11 in java.library.path, no jansi in java.library.path, There is not enough space on the disk]
 at org.fusesource.hawtjni.runtime.Library.doLoad(Library.java:182)
 at org.fusesource.hawtjni.runtime.Library.load(Library.java:140)

Cause

This happens due to the lack of disk space on the server which hosts Service Manager.

Action

Add disk space and restart Service Manager. The hardware requirements documented here provide general guidelines regarding the necessary hardware allocations for an Appian environment.

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: October 2018

Related
Recommended