KB-1779 Users are unable to receive email from Appian

Symptoms

User are unable to receive emails from Appian, and the following errors are noticed in the application server log after enabling additional email loggers

INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) YYYY-MM-DD HH:MM:SS.mmm [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - fromKey=processModel
INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) YYYY-MM-DD HH:MM:SS.mmm [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - Sender Option for [fromKey]: null
INFO  [stdout] (Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest) YYYY-MM-DD HH:MM:SS.mmm [Appian Work Item - 1 - ProcessExec00 : UnattendedJavaActivityRequest] DEBUG com.appiancorp.process.runtime.activities.SendEmailActivity - Not setting 'Sender' header

For JBoss, sever.log is located in the <JBOSS_HOME>/standalone/log directory. For Tomcat, tomcat-stdOut.log file is located in the <APPIAN_HOME>/log directory.  

Cause

This issue occurs when the Email service is turned off from the Admin Console, or if the custom.properties file located in the <APPIAN_HOME>/conf directory is missing proper configurations as explained in the Mail Server Setup documentation.

Action

  1. Ensure that Appian is allowed to send emails by selecting the "Allow Appian to send email" tab on https://<site-name>/suite/admin/page/email.
  2. Perform the mail server testing procedures to validate the existing configurations.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: November 2018

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