KB-1795 Users do not receive alerts for failed processes due to MAX_RECIPIENTS being exceeded

Symptoms

Users are not receiving alerts for failed processes or email messages for processes paused by exception.

The following error is seen in the application server log: 

INFO [stdout] (ajp-/0.0.0.0:8009-11) [ajp-/0.0.0.0:8009-11] WARN com.appiancorp.ap2.service.PortalNotificationServiceJavaImpl - A notification broadcast has been prevented because the number of recipients [***] would exceed the configured limit of [100]. Adjust conf.notifications.MAX_RECIPIENTS to a value greater than [100] as necessary for future notifications.

For JBoss, server.log is located in the <JBOSS_HOME>/standalone/logs directory. For Tomcat, tomcat-stdOut.log file is located in the <APPIAN_HOME>/log directory. 

Cause

To prevent accidental mass notifications, if a notification is generated for more than a certain number of recipients, the system sends a WARN message to the application server log and does not send the email, mobile push notification, or portal alert notification to the recipients.

Action

This recipient limit is controlled by the following property in custom.properties:

conf.notifications.MAX_RECIPIENTS=

The default value is 100. To send out the email to more than 100 recipients, you can increase this value and restart the application-server to send out the email to more than 100 recipients.

This documentation provides additional information on this topic. 

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: November 2018

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