KB-1787 HTTP 503 Service Unreachable with "Failed opening socket: Connecting to backend failed" error when attempting to access the Appian login page

Symptoms

Apache Web Server has been configured to work with Appian, and all components of Appian are running successfully. Apache is running successfully, and it is reachable on the port configured with HTTPS.

However, trying to reach https://<SITE_URL>/suite fails with HTTP 503 Service Unreachable and the following error in mod_jk.log:

Failed opening socket to (::1:8009) (errno=111) 
connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=111)
sending request to tomcat failed (recoverable), because of error during request sending (attempt=2)
connecting to tomcat failed.
service failed, worker <NODE_NAME> is in error state
All tomcat instances are busy or in error state
All tomcat instances failed, no more workers left

Cause

The value in the field JKWorkerProperty worker.<NODE_NAME>.host does not match the IP address that the application server is running on.

Action

Ensure that the value in the field JKWorkerProperty worker.<NODE_NAME>.host matches the IP of the web server, as mentioned in Configuring Apache Web Server with Appian.

Affected Versions

This article applies to all versions of Appian using Apache as the Web Server.

Last Reviewed: November 2018

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