KB-1895 Execution engines fail to start with "pe.kr: file not found" message in the db_PX* log file

Symptoms

Execution engine fails to start due to the following error printed in the service_manager.log file located in the <APPIAN_HOME>/logs directory: 

ERROR com.appian.komodo.engine.EngineComponentService - execution01 failed to start with context RestartContext{mode=REPLICA, epoch=null, restart=true, attempt=3}
java.lang.RuntimeException: com.appian.komodo.engine.invoker.SignalReturnedException: Signal returned by engine: type
...
Caused by: com.appian.komodo.engine.invoker.SignalReturnedException: Signal returned by engine: type

The following error is printed in db_PX*.log file located in the <APPIAN_HOME>/logs directory:

[PX011] {pe1045.kdb ,0} () FATAL .a.db "pe.kr: file not found"

Cause

This issue is witnessed when the pe.kr file located in <APPIAN_HOME>/server/process/exec is missing. This file is utilized to build KDB files for the execution engines. 

Action

  • Restore the pe.kr file from a backup or from another install on the exact Appian version.
  • Start the execution engines again as noted in the Start Script documentation.

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: March 2019

Related
Recommended