KB-1912 Editing Target or Permissions for a Portal channel fails with a "The system has encountered a problem" error

Symptom

When attempting to open the Target or Permissions settings for a Portal channel, the following error is observed:

The system has encountered a problem
We're sorry! A problem occurred while processing your last request.
Please contact the system administrator for more information.

In the application server log, the following error is observed:

10:41:06,858 INFO  [stdout] (ajp-/0.0.0.0:8009-24) 2018-10-11 10:41:06,857 [ajp-/0.0.0.0:8009-24] ERROR com.appiancorp.ap2.WrapFilter - java.lang.NullPointerException
10:41:06,858 INFO  [stdout] (ajp-/0.0.0.0:8009-24) java.lang.NullPointerException
10:41:06,858 INFO  [stdout] (ajp-/0.0.0.0:8009-24)      at com.appiancorp.security.BlockPortletFilter.doFilter(Unknown Source)
10:41:06,858 INFO  [stdout] (ajp-/0.0.0.0:8009-24)      at com.atlassian.plugin.servlet.filter.DelegatingPluginFilter.doFilter(DelegatingPluginFilter.java:74)

Cause

This issue is caused by a bug in the appian.system.block-portlet-1.0.0.jar plugin.

Action

As of the hotfix versions listed below, a fixed version of the functionality the plugin provided is now part of the Appian product, and the plugin is no longer necessary.

  1. Before proceeding, ensure your environment is running the following hotfix package/version or a later one. Appian recommends always applying the latest hotfix package as soon as one becomes available.
  2. Once your environment is running an appropriate hotfix/version, undeploy the appian.system.block-portlet-1.0.0.jar plugin.

Affected Versions

This article applies to Appian 17.2 and later.

Last Reviewed: April 2019

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