KB-1985 Current user activity fails to clear even after the user has logged out

Symptoms

After logging out of the environment, the Current User Activity page in the Admin Console continues to show that the user is still active. In the screenshot below taken on August 20th, we see user activity that is months old still listed.

Cause

This issue has been reported to the Appian Product Team. The reference number for this issue is AN-139529.

Action

Execute the following command to resolve the issue:

Linux

curl -XPOST --header "Authorization: Basic YWRtaW46YQ" "localhost:9200/user-activity/_delete_by_query" -H 'Content-Type: application/json' -d' { "query": { "match_all": {} } }'

Windows

Note: Run the command in PowerShell or Command Prompt (cmd.exe), if it is configured to run as PowerShell.

Invoke-RestMethod -Method Post -Uri "http://localhost:9200/user-activity/_delete_by_query" -Header @{"Authorization" = "Basic YWRtaW46YQ=="} -Body '{ "query": { "match_all": {} } }' -ContentType "application/json"

Verify that the following message appears after running the above command:

{"took":X"timed_out":false,"total":X,"deleted":X,"batches":1,"version_conflicts":0,"noops":0,"retries":{"bulk":0,"search":0},"throttled_millis":0,"requests_per_second":-1.0,"throttled_until_millis":0,"failures":[]}w

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: August 2019

Related
Recommended