KB-1995 Unable to log in using a custom Android mobile application

Symptoms

Users using a customized Android version of Appian for Mobile Devices with a hardcoded URL configured are unable to log in and out of the mobile application successfully. Instead, the behavior is as follows:

  1. Logging in initially works as expected.
  2. After logging out and logging back in, the user is redirected to the web authentication page for Appian. After re-entering credentials, login is successful.
  3. After logging out and logging back in, the user is unable to log in and the following error is observed in the diagnostic logs:
httpAuth was not defined. Not handling textChange.
java.lang.NullPointerException

Cause

This issue has been addressed in version 19.3 of the Appian for Mobile Devices application for Android.

Action

Use the Mobile Branding application on Appian Forum to request the latest Android build of Appian for Mobile Devices and deploy it to end users using your preferred distribution method.

Affected Versions

This article applies to customized builds of Appian for Mobile Devices 19.2 and earlier.

Last Reviewed: September 2019

Related
Recommended