KB-2181 Emails from Appian not received by end users after changing site domain and/or custom email sender

Symptoms

After a change to the site domain or the creation of a custom email sender, users are reporting emails from Appian are not being delivered.

Cause

Changes to the site domain or the configuration of a custom email sender may change the domain that emails are sent from by the environment. Often, these changes also require an update to the SPF record for your domain to include the Appian SPF record. Without these updates, the Appian Cloud site may not be authorized to send email on behalf of the new domain, which can cause the emails to be blocked by the recipient.

Action

To address this issue, do the following:

  1. Check the SPF record that the Appian Cloud site is using. This can be done by following KB-2010.
  2. Provide the canonical name value to your mail server administrators so they can add an include record for the Appian Cloud sites SPF record.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: April 2021

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