KB-1033 "k3.lic" error when running engine scripts

Symptoms

When executing start-suite.bat|sh, stop-suite.bat|sh, or checkengine.bat|sh, the script will fail to run successfully.

In Appian 17.2 and earlier, k3.lic is printed in the console.

In Appian 17.3 and later, the following error will be printed in the service_manager.log:

ERROR com.appian.komodo.engine.KLicenseVerifier - Error starting K: k3.lic 

Cause

The license for this environment is invalid for at least one of the following reasons:

  1. There was a change in the operating system.
  2. There was a change in the CPU count.
  3. The FQDN was changed.
  4. The license expired.
  5. More than one hostname resolves to the local network IP of the machine where this license is installed.

Action

Ensure that your network's DNS servers don't resolve multiple FQDNs to a single IP.

If that doesn't work, request a new license from Appian Support by following KB-1316.

Note: licenses can be hot-deployed, so a shutdown of the environment is not necessary when applying the new license.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: November 2017

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