KB-1059 Users are unable to log in to Appian using LDAP or SAML authentication

Symptoms

Users are unable to login to Appian using LDAP or SAML authentication.

Cause

This can occur for one of the following reasons:

  • The password of the account used to establish a connection to the LDAP server has changed.
  • There are some users in Appian that do not login using LDAP and the Restrict LDAP authentication to a specific group checkbox in the Admin Console under Authentication > LDAP Authentication is not enabled.
  • There are some users in Appian that do not login using SAML and the Restrict SAML authentication to a specific group checkbox in the Admin Console under Authentication > SAML Authentication is not enabled.
  • The connection information to the SAML IdP has changed.
  • The connection information to the LDAP server has changed.

Action

Log into the system as a non-LDAP or non-SAML user that has access to the Admin Console to disable this setting. You can force the system to use Appian authentication by modifying your Appian URL to point to <SERVER_AND_PORT>/suite/portal/login.jsp.

If that does not resolve the issue, open a case with Appian Technical Support.

Affected Versions

This article applies to Appian 7.10 and later using LDAP authentication and Appian 7.11 and later using SAML authentication.

Last Reviewed: January 2020

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