KB-2263 Active k4.lic fails license check post upgrade or hotfix with error code "upd"

Symptoms

After upgrading Appian, the Data Server is not able to start even though the license is still active.

  • The following error is shown inside the <APPIAN_HOME>/logs/data-server/watchdog.log, indicating that the license can not be validated:
{"level":"ERROR","time":"YYYY-MM-DDTHH:MM:SS.MSZ","logger":"watchdog","caller":"QLicenseManager.java:54","thread":"main","msg":"An unexpected error Failed to start and connect to q. cfg=Config{script=lib/ut.q, hostAndPort=localhost:5406, args=[]} occurred during K4 license validation. For an updated license, please contact Support."}
java.lang.IllegalStateException: Failed to start and connect to q. cfg=Config{script=lib/ut.q, hostAndPort=localhost:5406, args=[]}
  • Following the license check for "k4.lic," the output displays error code "upd":
<APPIAN_HOME>/data-server/engine/bin/q/l64$ QHOME=.. ./q 

'YYYY.MM.DDTHH:MM:SS.MS license error: upd

Cause

The current k4.lic file does not support the version of q present in the upgraded Appian version. This is due to a change in the q version between the initial Appian version and the upgraded Appian version.

The k4.lic file needs to be updated if the Appian version you are upgrading to has a q version that was released later than when your license was last updated.

Action

  1. Replace the k4.lic file with a new temporary license.
    1. Steps to request for temporary licenses can be found in the documentation.
  2. Open a support case to request for refreshed licenses.

Affected Versions

This article applies to all self-managed versions of Appian.

Last Reviewed: August 2024

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