KB-2317 Deployment Failed with required precedent is missing SYSTEM_RECORD_TYPE_USER

Symptoms

When deploying a Solution such as Case Management Studio into an environment, missing precedent errors regarding SYSTEM_RECORD_TYPE_USER are returned similar to the following:

The content [id=] was not imported because a required precedent is missing: recordField [uuid=SYSTEM_RECORD_TYPE_USER_FIELD_username location=Expression Rule Definition] in record type [id=1 uuid=SYSTEM_RECORD_TYPE_USER] cannot be found. (APNX-1-4070-005) (APNX-1-4071-006)

Cause

More recently developed Solutions, such as Case Management Studio, rely on an updated version of the User record type. If a customer has an environment that has existed prior to 22.4, and they have not updated the User record type to the more modern version, then the deployment will fail due to missing precedents of User record type.

Action

Update the default User record to the modern version of the record and redeploy the Solution.

Refer to the following documentation for more information on the steps to update.

Affected Versions

This article applies to Appian versions 22.4 and later that do not yet have the updated User record type.

Related
Recommended