KB-2328 Data Server hangs on startup

Symptoms

When starting Appian, the data server hangs on the following line in watchdog.log while the q engines are starting.

{"level":"INFO","time":"YYYY-MM-DDTHH:MM:SS.mmmZ","logger":"watchdog","caller":"QStarter.java:78","thread":"process-starter-4","msg":"Starting Q process: Config{script=rts.q, hostAndPort=localhost:5453, args=[-rts, 1]}"}

Eventually, if given enough time, the watchdog.log will print the following line:

Caused by: io.vertx.core.http.WebsocketRejectedException: Websocket connection attempt returned HTTP status code 401

Cause

The data-server-sec.properties file, found in <APPIAN_HOME>/data-server/conf does not have a valid value.

This can occur due to one or more of the following:

  • Duplicate entries.
  • Invalid unicode characters.
  • Password is longer than expected.

Action

  1. Stop the Data Server.
  2. Ensure that a value is specified for dataserver.password in the data-server-sec.properties file and is valid.
    1. For high availability (HA) sites, ensure that the value is the same on all nodes of the cluster.
  3. Save the changes.
  4. Ensure that the value matches the data-server-sec.properties located in <APPIAN_HOME>/conf
    1. For high availability (HA) sites, ensure that the value is the same on all nodes of the cluster.
  5. Start Data Server.

If the issue persists, please open a case with Appian Support.

Affected Versions

This article applies to all self-managed versions of Appian.

Last Reviewed: January 2025

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