KB-2350 Access is Denied observed in Data Server Logs

Symptoms

The Appian Data Server (ADS) Appender component engages in .no-op when access denied errors are observed in the appender-gateway.log (located in <APPIAN_HOME>/logs/data-server).

{"level":"ERROR","time":"YYYY-MM-DDTHH:MM:SS.mmmZ","logger":"appender-gateway","caller":"ss/cleaner.go:535","msg":"Snapshot cleanup: failed to cleanup old directory for attribute or view","pid":<PID>,"hostname":"localhost","dir":"#########","error":"remove <APPIAN_HOME>\\data-server\\data\\ss\\#########\\#########\\idx\\#########\\tbl: Access is denied." ...
{"level":"ERROR","time":"YYYY-MM-DDTHH:MM:SS.mmmZ","logger":"appender-gateway","caller":"binge/assimilator.go:141","msg":"Failed to move the binge's HS tables into the ADS HS directory","pid":9572,"hostname":"localhost","error":"rename <APPIAN_HOME>\\data-server\\data\\pantry\\binge\\#########\\hs\\######### <APPIAN_HOME>\\data-server\\data\\hs\\#########: Access is denied." ...
{"level":"WARN","time":"YYYY-MM-DDTHH:MM:SS.mmmZ","logger":"appender-gateway","caller":"noop/no_op.go:106","msg":"Putting the component in noOp","pid":9572,"hostname":"localhost"}

This may result in issues with Record Syncs as seen in tomcat-stdOut.log (located in <APPIAN_HOME>/logs/) or increased disk usage due to ADS.

YYYY-MM-DD HH:MM:SS,mmm [RecordSyncScheduler_Worker-2] ERROR com.appiancorp.record.service.BulkLoadServiceImpl - Error syncing record type with uuid: <UUID> com.appiancorp.suiteapi.common.exceptions.AppianException: Unable to sync due to a system failure. (APNX-1-4521-044) 
...
Caused by: com.appian.data.client.AdsException: APNX-3-0000-027: The appender is not up to date: [TxID]. Requested last transaction id: <TxID>

Cause

These errors still seem to indicate an antivirus scanner or another process is blocking access to those files and its child directories, causing the observed failures.

Action

  1. Ensure that ADS has been excluded from any anti-virus scanners as per the documentation.
  2. Run ProcMon and set it up to monitor <APPIAN_HOME>\data-server\data
  3. Start ADS and see what processes are accessing the files in there.
  4. Disable the identified processes.
  5. Restart ADS and monitor if the issues persist.

If issues persist, please reach out to Appian Support for further investigation.

Affected Versions

This article applies to all self-managed versions of Appian.

Last Reviewed: September 2025

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