KB-2360 A user is locked out due to accessing an invalid task too many times.

Symptoms

A user is unable to access a task even though it has been correctly assigned. 

Below are a few instances of the front end errors that users may observe:

  • "User does not have permission to view this task" 
  • “Task does not exist”
  • “Task is canceled or completed”

Additionally, the below error is logged in <APPIAN_HOME>/logs/tomcat-stdOut.log

ERROR com.appiancorp.process.engine.TaskErrorRateLimiter - A user with UUID <REDACTED> is temporarily restricted from accessing any tasks due to viewing too many invalid tasks.

Cause

The above messages indicate that an invalid task has been accessed by a user too many times. Appian has a rate limit that kicks in if users experience too many errors in a short window. If an invalid task has been accessed more than 10 times in a 15 minute time span, the user who is attempting to access the invalid tasks will temporarily be locked out from tasks.

Action

The lockout period ends after a duration of 15 minutes and the user should then be able to access tasks as expected. Please note that there are no exceptions to this rule and the lock-out duration is non-configurable. 

To determine which user(s) this is impacting, you may search for the mentioned UUID(s) in the Admin Console or Appian Designer search bar to find the impacted user(s).

Affected Versions

This article applies to all versions of Appian. 

Last Reviewed: October 2025

Related
Recommended