KB-1172 "Error copying the Appian document to the remote server... Caused by: 4: Write exception: There is not enough space on the disk" error thrown when running SFTP smart service
Symptoms
The SFTP smart service fails with an error code of 4. The following is season in the application server log
[ajp-/0.0.0.0:8009-11] ERROR com.appiancorp.process.engine.UnattendedJavaActivityRequest - An error occurred while executing activity: id=##SOME ID##, classname=com.appian.ps.plugins.sftpsmartservices.SendFileOverSFTP [stdout] (ajp-/0.0.0.0:8009-11) com.appiancorp.suiteapi.process.exceptions.SmartServiceException: userMsg[error.file_transfer=Error copying the Appian document to the remote server. See application server log for more details.] INFO [stdout] (ajp-/0.0.0.0:8009-11) Caused by: 4: Write exception: There is not enough space on the disk.
Cause
This happens because the SFTP server does not have sufficient disk space to receive the file. A more exhaustive list of SFTP error codes can be found here.
Action
You should either add more storage or free up some space on the SFTP server and try the transfer again.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: March 2017
