KB-1190 Authentication-related errors are printed in the application server log even though the data source validates successfully in the front end

Symptoms

With the release of Appian 16.1, users are able to configure data sources in the Admin Console. If the connection string and username/password are defined correctly in the data source in the Admin Console, users should have no trouble performing database-related operations inside of Appian. Even if there is a data source with the same JNDI name configured directly in the application server with a different connection string/incorrect username or password, there will be no loss of functionality in the front end.

That being said, if an application server data source with the same JNDI name as an Admin Console data source has an incorrect connection string/username/password, users may see errors in the logs related to authentication failing/incorrect username or password for that data source.

A scenario where this issue could occur is as follows:

  1. Create a business data source in the application server with an incorrect password.
  2. Create a business data source in the Admin Console with the corret password.
  3. Verify a data store or try to access data from the business data source. There is no loss of functionality in the front end, however there will be errors printed related to authentication failures in the application server log.

Cause

This issue has been reported to the Appian product team. The reference number for this issue is AN-71183.

Action

There are two ways to overcome this issue:

  • Remove the business data source entirely from the application server and solely use the data source from the Admin Console.
  • Update the data source in the application server to use the correct connection string/username/password.

Affected Versions

This article applies to Appian 16.1 and later.

Last Reviewed: March 2017

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