KB-1234 "Could not process received email... java.lang.NumberFormatException" error thrown when attempting to start a process via email

Symptoms

When attempting to start a process via email, at least one the following errors is seen in the application server log:

Error 1:

ERROR com.appiancorp.messaging.MessagePublisherServiceImpl - Could not process received email
java.lang.NumberFormatException: For input string: "<XXXX>"

Error 2:

ERROR com.appiancorp.mdb.EmailHandlerBean - Error receiving message in EmailHandlerBean MDB
javax.mail.MessagingException: Message could not be sent;
nested exception is:
java.lang.NumberFormatException: For input string: "<XXXX>"
...
Caused by: java.lang.NumberFormatException: For input string: "<XXXX>"

Cause

This issue occurs when an invalid character is found in the parameter after the corresponding destination key (process, processmodel, event) in the email address used to start the process.

For instance, in process<id>@appian.com, <id> should only consist of numbers, but if a non-numeric character is inserted somewhere in the <id> parameter, then the NumberFormatException error will be thrown.

Refer to Sending an Email Message to a Process for more information.

Action

There are two solutions:

  1. If you are polling an email account that contains an Appian keyword from the list below, enable an alternate name to remove it from the email address and send the emails to the alternate name instead (e.g., change "ProcessXYZ@appiancorp.com" to "ProcXYZ@appiancorp.com"). Note: The Appian email-related keywords are process, event, processmodel, and processmodeluuid.
  2. When using an email address that begins with an Appian email-related keyword, use the following formats:
    • process<id>@domain.com
    • event<eventId>@domain.com
    • processmodel<id>@domain.com
    • processmodeluuid<model_uuid>@domain.com

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: March 2017

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