KB-1239 "An unexpected error occurred while trying to load the keystore... Caused by: java.io.IOException: No locks available" error thrown during application server startup
Symptoms
In a Linux Environment, the application server fails to start.
This error is seen in the server.log:
com.appiancorp.common.config.FatalConfigurationException: com.appiancorp.suiteapi.common.exceptions.AppianException: An unexpected error occurred while trying to load the keystore. (APNX-1-4210-005)
...
Caused by: java.io.IOException: No locks available
Cause
The lockd daemon isn’t running on the NFS server. This daemon is needed to process lock requests. When it's not running, lock requests can't be processed.
The lockd daemon is needed to acquire a lock on the appian.keystore.lock file located in <APPIAN_HOME>/_admin/shared directory on the NFS server.
Action
Restart the lockd daemon, then restart the application server.
Affected Versions
This article applies to all versions of Appian.
Last Reviewed: March 2017
