KB-1298 "No acknowledgement from TransientTopic" error thrown in the application server log

Symptoms

One or both of the following errors are seen in the application server log:

[Appian Timer - 0] ERROR com.appiancorp.messaging.TransientTopicHeartbeat - No acknowledgement from TransientTopic in 60 seconds, forcing rules cache to be cleared now.
[Appian Timer - 0] ERROR com.appiancorp.cache.persist.JmsCacheUpdateDistributor - Could not propagate: DistributedCacheClear [cacheName="local_repository"]
javax.jms.JMSException: HQ119001: Failed to create session
...
Caused by: java.lang.IllegalStateException: Connection is null
at org.hornetq.core.client.impl.ClientSessionFactoryImpl.createSessionInternal(ClientSessionFactoryImpl.java:838)
... 16 more


[ajp-/0.0.0.0:8009-39] ERROR com.appiancorp.cache.persist.JmsCacheUpdateDistributor - Could not propagate: DistributedCacheRemove [cacheName="groupMemberships" keys=[xyz]] javax.jms.JMSException: HQ119001: Failed to create session ... Caused by: HornetQException[errorType=INTERNAL_ERROR message=HQ119001: Failed to create session] ... 100 more Caused by: java.lang.IllegalStateException: Connection is null at org.hornetq.core.client.impl.ClientSessionFactoryImpl.createSessionInternal(ClientSessionFactoryImpl.java:838) ... 99 more

Cause

The message means that the mechanism that propagates information about rule and constant definition changes across multiple application servers did not receive the message that it uses to ensure that it is still connected. This mechanism is used whether or not multiple application are servers configured.

These messages indicate that there’s a cache that is not functioning correctly and the system will be clearing it every 60 seconds so that the rule and constant definitions on the application server are not more than 1 minute out of date.

Action

To alleviate the behavior, perform one of the following:

  1. Make sure your JMS Clustering settings are correct:
  2. Upgrade to Appian 16.3. The rule and constant propagation mechanism has been modified not to be dependent on JMS starting in this version.
  3. Restart the application server. Note: This does not guarantee the issue will not reoccur at a later time and should be treated as a temporary fix.

Affected Versions

This article applies to Appian 16.2 and earlier.

Last Reviewed: March 2017

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