KB-1311 Tempo entry with attachment of size greater than 2 GB causes News not to render properly
| This issue has been resolved in an Appian hotfix/new Appian version. Please apply the latest hotfix to your Appian installation or upgrade to the latest version of Appian. |
Symptoms
Tempo is unable to render News properly. Navigating to News displays a page like the following:
The following error is thrown in the application server log at the same time:
2016-04-13 16:13:13,702 [http-/0.0.0.0:8080-3] ERROR com.appiancorp.abdera.AtomEntryCollectionAdapter - An internal error occured while accessing the tempo feed
java.lang.IllegalArgumentException: kiloBytes = -1552522.98 < 0
at com.appiancorp.content.util.SizeConversionUtils.formatKiloBytes(SizeConversionUtils.java:73)
at com.appiancorp.content.util.SizeConversionUtils.formatKiloBytes(SizeConversionUtils.java:99)
at com.appiancorp.content.util.ServerSizeConversionUtils.formatSizeKB(ServerSizeConversionUtils.java:29)
Cause
This issue is caused by an attachment on a News post greater than 2 GB in size. This has been resolved via a security update in the following hotfixes/versions:
- Appian 7.8 (latest hotfix)
- Appian 7.9 (latest hotfix)
- Appian 7.10 (latest hotfix)
- Appian 7.11 (latest hotfix)
- Appian 16.1 (latest hotfix)
- Appian 16.2 (latest hotfix)
- Appian 16.3 (latest hotfix)
- Appian 17.1
Action
Apply the latest hotfix to your Appian installation or upgrade your version of Appian.
Affected Versions
This article applies to Appian 16.3 and earlier.
Last Reviewed: July 2017

