KB-1312 Date fields do not render in Appian 17.1 when using specific time zones

Symptoms

When opening an interface containing a date field in Appian 17.1, the date drop down no longer displays:

It should display like this:

Cause

This issue occurs with using certain time zones in Appian. One example is (UTC-06:00) Central Time (CST).

This issue has been reported to the Appian product team. The reference number for this issue is AN-82746.

Action

To correct this behavior, change the current time zone from its current setting to another equivalent time zone.

Users can change this at the user level by performing the following:

  1. Log in to Tempo.
  2. Select the profile icon in the top-right portion of the window and go to Settings.
  3. Under Regional, change the Time Zone field from its current value to a different time zone in the drop down matching your current time zone.

System administrators can change this at the environment level by performing the following:

  1. Log in to Appian and navigate to <APPIAN_URL>/suite/designer.
  2. Select the System tab.
  3. In the side bar, navigate to System Administration HomeInternationalizationInternationalization Settings.
  4. Change the Primary Time Zone field from its current value to a different time zone in the drop down matching your current time zone.

If you do not select the check box named Always override users' selected time zone, then changing this setting in /designer will only affect users whose setting in Tempo is configured to use the system default. In this scenario, any user that has a time zone set other than default will not change after changing this setting in /designer.

If you do select the check box named Always override users' selected time zone, then all users in the system, regardless of their current setting in Tempo, will be updated to use the system default.

Affected Versions

This article applies to Appian 17.1 and later.

Last Reviewed: August 2017

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