KB-1358 Tempo does not load for basic users until system administrator logs in

Symptoms

Upon application server restart, Tempo does not load for basic users until the system administrator logs in. Basic users will not see any tabs or news posts after successfully logging in.

Cause

This issue is caused by the security set on the User record. The default group (all other users) is set to No Access and no system administrator user has attempted to log in to Appian since the application server started.

Action

Ensure the default group has at least Viewer privileges over the User record. This can be set in /design.

Starting in Appian 17.2, users are unable to set No Access to this object to prevent issues like the one described in this article from occurring.

Affected Versions

This article applies to all versions of Appian.

Last Reviewed: June 2017

Related
Recommended