KB-1289 Configuring an exception timer in months causes causes the exception to trigger thousands of years in the future

This issue has been resolved in a new Appian version. Please upgrade to the latest version of Appian.

Symptoms

Users have the ability to start nodes after a certain number of minutes/hours/days/months of the previous node completing in a process model.

When configuring a node to start a certain number of months after the previous node completes, one may notice the node never activates and the schedule displays a year far in the future (thousands of years):

Cause

This issue has been reported to the Appian product team. This issue has been addressed via AN-63987 and AN-78881 in Appian version 18.2 GA and later.

Action

Upgrade to the latest version of Appian.

Workaround

To fix this issue for existing models with active process instances, perform the following:

  1. Change the timer to trigger after a certain number of days instead of months (e.g., 180 days instead of 6 months). Save and publish the model
  2. Download and install the Process Management Services shared component.
  3. Using the Process Management Services smart services, build a process model that does the following:
    1. Upgrades all processes you specify (by ID) using either the Upgrade Process or Upgrade Process From Version smart services.
    2. Cancels all active nodes configured with the problematic timer settings in those processes, using the Cancel All Nodes smart service.
    3. Starts all nodes cancelled in the previous step in those processes, using the Start All Nodes smart service.
  4. Run that process model during off-peak hours, as this could put considerable load on the system.

Affected Versions

This article applies to Appian 18.1 and earlier.

Last Reviewed: May 2020

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