KB-1394 Emails are not sent to Appian Cloud because of CNAME expansion

Symptoms

Emails sent to a process model in an Appian Cloud environment are not started.

If analyzing traffic exiting the SMTP server, users will see their site URL resolve to a different URL than their actual site. For instance, mysite.appiancloud.com may be changed to mail-us-east-1.mail.appiancloud.com, so emails will leave the SMTP server with destination processmodel<id>@cloud_us-east-1_vpc_glb.appiancloud.com or the like. Appian cloud will not route the email to your Appian Cloud site, thus no process instances start.

Cause

CNAME expansion is enabled on the SMTP server.

This is often seen with Sendmail's default configuration value for DontExpandCnames (false). A snippet of their docs about this setting are as follows:

[False] If set, $[ ... $] lookups that do DNS based lookups do not expand CNAME records.  This currently violates the published standards, but the IETF seems to be moving toward legalizing this.  For example, if "FTP.Foo.ORG" is a CNAME for "Cruft.Foo.ORG", then with this option set a lookup of "FTP" will return "FTP.Foo.ORG"; if clear it returns "Cruft.FOO.ORG".  N.B. you may not see any effect until your downstream neighbors stop doing CNAME lookups as well.

RFC 2821 and RFC 5321 state the following:

The lookup first attempts to locate an MX record associated with the name.  If a CNAME record is found instead, the resulting name is processed as if it were the initial name.

Action

To address this behavior, work with your IT team to disable CNAME expansion on your email server.

Affected Versions

This article applies to all versions of Appian Cloud.

Last Reviewed: August 2017

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