KB-1464 Cannot edit username when testing LDAP connection

Symptoms

When configuring an LDAP connection, the username to test the connection with cannot be edited. As a result, an incorrect username may be displayed on the test screen, preventing testing and saving the configurations successfully.

Cause

If LDAP authentication is not restricted to a group or if the currently logged in user is part of the LDAP authentication group, Appian automatically assumes that the currently logged in user's credentials should be used to test the connection.

Action

If there is no LDAP user corresponding to the name of the currently logged in user, perform the following to enable editing the LDAP username:

  1. If LDAP authentication is not already restricted to a group, check the "Restrict LDAP authentication to a specific group" checkbox in LDAP settings in the Administration Console.
  2. Restrict LDAP authentication to a group that does not contain the currently logged in user.

If there is an LDAP group already configured:

  1. Remove the currently logged in user from the group.
  2. On the LDAP settings page, use the X next to the LDAP group to blank out the group selection.
  3. Start typing the group name into the "Appian LDAP Group" picker and re-add the same group as the LDAP group.

Alternatively, you may temporarily replace the LDAP group with another one that does not contain the user. The group setting will not impact the ability to test and can be replaced with the actual LDAP group after the test is successful.

Affected Versions

This article applies to Appian 7.11 and later.

Last Reviewed: January 2018

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