KB-1532 Process design and personalization engines constantly checkpointing and filling up disk space

Symptoms

For a given interval of time, both the process design and personalization engines are checkpointing often, causing issues with disk space. The following is shown in the service_manager.log:

[KomodoEventBus-29] INFO  com.appian.komodo.engine.checkpoint.AutoCheckpointer - Automatic checkpointing enabled for channels, triggered after every 100000 transactions or every 22 hours.
[KomodoEventBus-32] INFO  com.appian.komodo.engine.checkpoint.AutoCheckpointer - Automatic checkpointing enabled for notifications-email, triggered after every 100000 transactions or every 22 hours.
[KomodoEventBus-58] INFO  com.appian.komodo.engine.checkpoint.AutoCheckpointer - Automatic checkpointing enabled for forums, triggered after every 100000 transactions or every 22 hours.
[KomodoEventBus-8] INFO  com.appian.komodo.engine.checkpoint.AutoCheckpointer - Automatic checkpointing enabled for download-stats, triggered after every 100000 transactions or every 22 hours.

Cause

The following settings in custom.properties, if not adjusted to the environment needs/usage, can cause engines to checkpoint more frequently and affect the increase in disk space:

ServiceManager.checkpoint.automatic.boundary.replay

  • Setting used to checkpoint after a given time period. The default unit is milliseconds unless you specify Ex) 30 minutes 

ServiceManager.checkpoint.automatic.boundary.transaction

  • Setting used to checkpoint after a given number of transactions. 

Action 

  1. Edit custom.properties, located in <APPIAN_HOME>/ear/suite.ear/conf.
  2. Set the appropriate time unit for the ServiceManager.checkpoint.automatic.boundary.replay setting.
  3. Increase the transaction boundary for the ServiceManager.checkpoint.automatic.boundary.transaction setting.
  4. Restart Service Manager for the changes to take affect. 

Affected Versions

This article applies to Appian 17.3 and later.

Last Reviewed: April 2018

Related
Recommended